POwerMac G3 B&W broken? please help

Discussion in 'PowerPC Macs' started by mp3neo, Aug 24, 2008.

  1. mp3neo macrumors newbie

    Aug 24, 2008
    hi there.

    i recieved a PowerMac G3 B&W pci edition today.
    The last owner told me it dint work, but...
    i connected al my cables. i started de mac (with cover open).
    it runs i heard a nice jingle directly after i klikced the power button.
    but the was nog image on my (lcd) monitor connected with VGA cable.
    after a minute of 2~3 i've heard a beeb (maybe a error).
    i asumed the mac started correctly.

    disconnected power cable.
    i checked the videocard (PCI), disconnected en reinserted.
    checked some other stuff. seems OK.

    i reinserted the power cable and pushed the power button.
    NOTHING. not even a beeb or a fan.

    next checked. Bios battery removed en reinserted.
    cables checked.
    ram memory cheked. (it had a 128 pc100, 64 pc100, 256 pc133)
    tried al kinds of combination.
    psu checked for burn stink (in every electronics hides smoke when it comes out it dies) but every thing seems fine. but noting hapens.

    someone any idee, my imagination is out of options.
    much thanks in forehand.
  2. Firefly2002 macrumors 65816

    Jan 9, 2008
    I think perhaps either the hard drive is dead, or the system is "unblessed," which means it can't find the Mac OS (Operating System) and can't boot.

    But I can't explain why you got a beep after 2-3 minutes; I don't know that would be.

    You can try resetting the NVRAM (hold down the Apple Key + P + R during startup and wait for the jingle (boot chime) go three times. I think you may have already done this though (that was the PRAM battery you took out; there's no BIOS on PowerPC G3 Macs).

    You will want to recheck all your cable connections once again. Make sure the power is connected well to the main board.

    Take out all the RAM except one stick (preferably the 256 MB one) as well, and take out any PCI cards (other than the video card) you don't need.

    Make sure the hard drive jumper is set to Master (assuming it's supposed to be a master) and isn't conflicting with other drives.

    That's all I can think of, hope it helps a bit.
  3. mp3neo thread starter macrumors newbie

    Aug 24, 2008
    sorry i'm a PC man. this is the 1st mac that set foot in my home.

    what would that combination be on a lochitech pc keyboard ?

    but there is noting nog lights nog fan no beeb noting.
    so ill begin checking the battery.
  4. Firefly2002 macrumors 65816

    Jan 9, 2008
    Well if there are no lights or anything, it's definitely not powered... or you've managed to totally fry everything, which is highly unlikely.

    On a Logitech keyboard, the Windows key is equivalent to the Apple key.

    Check the main ATX connection to the motherboard.... also, make sure you didn't somehow disconnect the power button to the main logic board, which would mean the Mac wouldn't receive the signal to boot when you pressed the button.
  5. maccompaq macrumors 65816


    Mar 6, 2007
    When you first turned it on, you got some responses from the computer. Now, after removing hardware, you get nothing. No doubt, you burned out the power supply.

    Just to make sure, press the Power button on the front of the computer case, if nothing, press the Reset button below the Power button.

    On a PC keyboard, the Alt key is the same as the Cmd(Apple) key.
  6. monkey86 macrumors 6502


    Aug 5, 2008
    should all be the same speed ram (pc100) the 133 might be killing it.
  7. Firefly2002 macrumors 65816

    Jan 9, 2008
    No, PC133 will default to 100 speed no problem.
  8. maccompaq macrumors 65816


    Mar 6, 2007
    Pull the RAM sticks and try to start the computer with one stick installed. Then try another. Be very careful when handling the electronic components, because they are very sensitive to static electricity that can destroy them.
  9. mp3neo thread starter macrumors newbie

    Aug 24, 2008
    im not a n00b in electronics. im a System manager for over 5 years now.
    so tha careful handling with ram memory is taken care of.

    im just a MAC n00b.
    but after some wiggeling and reseting of the "cuda" tha mac responded to my calls. data recovered and its already running tiger as we speak.

    much tnx all.
    greats anton

    problem solved

Share This Page