PowerMac G3 Quicksilver won't load

Discussion in 'PowerPC Macs' started by ConfusedMacUser, Aug 11, 2008.

  1. ConfusedMacUser macrumors newbie

    Joined:
    Aug 11, 2008
    #1
    I have a power mac G3 which I have not used for sometime and over the last few days I have tried numerous times to turn it on to retrieve files, but O am having a problem the screen will turn on and the tower is receiving power as it is starting up and I am hearing the usual weiring sound but after a few second it dies.. and nothing!

    I checked the cables are not loose at the back and I have tried opening the side and making sure nothing is loose and blowing out any dust but I still have had no sucess..

    Does anyone have any suggestions... as to what I could try I am not the most technically minded so if you could dumb it down for me that would be great!!

    Thanks in advance...
     
  2. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Wichita KS
    #2
    So which is it? A Powermac G3 or a Quicksilver?
     
  3. revenuee macrumors 68020

    revenuee

    Joined:
    Sep 13, 2003
    Location:
    A place where i am supreme emporer
    #3
    thought the exact same thing when I saw the post
     
  4. Firefly2002 macrumors 65816

    Joined:
    Jan 9, 2008
    #4
    I'm sure he means QuickSilver G4. Whether it's a B&W G3 or a QS G4 really makes no difference, however.

    It sort of sounds like your PSU might be bad. The only other shot in the dark I can think of is resetting PRAM and NVRAM, but I sincerely doubt that would help. Always worth a try, however.

    You do hear the normal Mac OS chime from ROM, and not a crashing sound?
     
  5. ConfusedMacUser thread starter macrumors newbie

    Joined:
    Aug 11, 2008
    #5
    not G3 Quicksilver G4 sorry

    Hi guys sorry I checked and it is actually a Quicksilver G4, tried again last night to load it and i got the mac chime this time then nothing, after trying repeatedly it did actually load once but then crashed and turned off again once I opened a folder to retrieve a document and would not come back on after that... is the general consensus as i feared that it is not easily fixable by myself..

    thanks again

    Sam
     
  6. Firefly2002 macrumors 65816

    Joined:
    Jan 9, 2008
    #6
    It sounds like you have a bad PSU, or possibly a bad hard drive. I'm actually now leaning more towards a bad hard drive since you got it to boot all the way.

    Try booting from CD, and if that works, then you'll have a good idea.
     
  7. BornAgain macrumors newbie

    Joined:
    Aug 22, 2008
    Location:
    North Norfolk, UK
    #7
    That sounds just like my G4 Quicksilver when I accidently damaged the PSU. It got worse and worse, sometimes it would boot up for 2-3 seconds then turn off again, then finally, nada. Expensive mistake on my part. Might be worth scouting Ebay or similar for spares or a G4 with a different problem.
     

Share This Page