PowerMac G4 Cube not powering up

Discussion in 'PowerPC Macs' started by HighSpeedDirt, Apr 27, 2009.

  1. HighSpeedDirt macrumors newbie

    Joined:
    Apr 25, 2009
    Location:
    illinois
    #1
    Bought a new power supply thinking that was the problem still nothing and changed the internal battery and nothing. Dont want to send to apple due to finances being tight. Usually fix things myself so if anyone has some ideas on what i should look for i would be greatly appreciated.

    :mad:
     
  2. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #2
  3. CubeHacker macrumors 65816

    CubeHacker

    Joined:
    Apr 22, 2003
    #3
    When you plug the AC adapter into the wall and then into the Cube, do you see any LED lights turn on inside the cube itself, specifically on the motherboard (its either red or green, I forget exactly atm)? That can tell us if its getting power or not.
     
  4. HighSpeedDirt thread starter macrumors newbie

    Joined:
    Apr 25, 2009
    Location:
    illinois
    #4
    well its been awhile since i posted that and i have changed the dc board but still nothing. Already sold the powersupply i bought before so i guess it is Mother board. No lights at all when i plug in but when i did go to plug in to the wall after hooking dc board up it sparked when plugging to wall but didnt do it anymore. Would like to know if i should just take hard drive and ebay the rest or can it be an easy fix?? More help would be appreciated:confused:
     
  5. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Wichita KS
    #5
    I would highly reccomend posting your problem HERE for some input from what may be the last group of dedicated Cube owners/users. I haven't done enough with mine to really be of much help, but there might be someone over there who knows if you don't get an answer here.
     

Share This Page