Powermac G4 Cube Tiger Upgrade

Discussion in 'PowerPC Macs' started by lonegeek, May 26, 2009.

  1. lonegeek macrumors member


    Jan 2, 2006
    First off...UGH!

    I've recently gotten 2 free cubes. I threw in a random hard drive I got to, which had Tiger loaded up, and worked just fine on the cube. However, I obviously wanted to do a fresh install. Thought the drives were bad, so I swapped them. Turns out I need updated firmware.

    So I throw old hard drive back in and re-install OS9. Update to 9.1. Flash firmware. All is good.

    Put new hard drive in, Tiger install disc still doesn't boot /and it doesn't show up in the old Tiger install.

    What do I need to do to make tiger boot up and install?

    Thanks, Zach.
  2. Hrududu macrumors 68020


    Jul 25, 2008
    Central US
    You sure the install disk is good? Also, do the Cubes have the DVD-ROM drives or the CD-RW drives? If they happen to be the CD burners, then reading a Tiger DVD isn't going to happen.
  3. Theclamshell macrumors 68030

    Mar 2, 2009
    I have to agree and say they are most likeley cd drives do they wont read dvd but i am extremely envious of you getting free cubes :) im a huge fan of vintage macs and i think cubes were one of the coolest designs apple has had besides the Twentieth Anniversary Macintosh :p
  4. lonegeek thread starter macrumors member


    Jan 2, 2006
    I also snagged two dual 1.25 ghz powermac g4s...but the power supplies are toast. iBook G3 900mhz. Powerbook G4 867mhz.

    I swapped the drives around because I thought they were bad, and they say dvd rom on them. They're dvd drives.

    Just don't want to boot up tiger install disc.

    Going to try installing tiger on the other cube now and see what happens.
  5. shroud macrumors member

    Sep 24, 2007
    I put Leopard on my cube by using it in target disk mode while connected to my Mac Pro. Then I just put the leopard disk in the MP and chose the destination disk as the cube one.

    Tiger will work the same way provided your HDDs are fine.
  6. lonegeek thread starter macrumors member


    Jan 2, 2006
    I kinda had that going with the hard drive I found. I mean, tiger does run. Just not a fresh install and the disc drive doesnt seem to work in tiger.

    Not to mention, I don't have a firewire cable...yet.
  7. lonegeek thread starter macrumors member


    Jan 2, 2006
    No luck with other computer.

    It just spits out tiger disc in os 9 ( fully updated).

    I can't seem to find any guides or how to's to install tiger on to the cube.

    I'd like to avoid doing a target disc mode install.

    Any help?
  8. fernkorn macrumors newbie

    May 18, 2009
    I'm sorry to mention that. But how did you insert the DVDs in the drive? In which direction does the cover point? I'm asking you, because I also had to do this update and I spent an hour trying to boot from a DVD, before I noticed I had inserted the DVD the wrong way. ;)

    However, if you chose the correct way. Is your a Tiger DVD a retail DVD or did it ship with one of your other systems?
  9. lonegeek thread starter macrumors member


    Jan 2, 2006
    As far as I know its a retail disk. It came with all the other computers. I just took it out of shrink rap. I even just checked the numbers on it.

    It loads up on the one cube in os9 and says it wants to initialize the disc (erase).

    This is so frustrating.
  10. lonegeek thread starter macrumors member


    Jan 2, 2006

    Just tried the osx 10.3 Panther install CD and it loaded up in os9 and let me click restart, which resulted in the computer restarting and booting into the disc.

    Maybe I need to try to find tiger install CDs...
  11. wainwright.ian macrumors newbie

    Sep 2, 2007
    I have similar problems. Any solution?

    Hi all!

    I also have an old g4 Cube with 10.3 installed, but i want to instal tiger. Of course the tiger DVD wont work as the cube does not read DVD:s. I have an external DVD on firewire but that does not seam to work. So I have got hold of tiger CD:s! Now i reboot and hold "c" for disc boot, but it simply ejects the CD on start... I'v tried to firewire boot also over my macbook, but nothing happens if I hold "t" for firewire boot, except that it looks like it tries to go inte classic, but fails at that also.

    Has anyone got any ideas how to install tiger on the Cube? Any help is appreciated and I'll give response after I'v tried your solutions.


  12. MacVidCards Suspended

    Nov 17, 2008
    Hollywood, CA
    go to cubeowner.com

    someone there will have answer
  13. sommls macrumors member

    Sep 7, 2008
    When you updated, did you get the final firmware version available (I believe it was 4.1.9)? There was an intermediate update (don't recall number) that was not sufficient.


    Agree, too, check whether you're trying to read a DVD with a CD-only optical drive. MCE offered a slot loading DVD drive upgrade for some time; you might need that.
  14. sommls macrumors member

    Sep 7, 2008
    Can you insert the install CD and select it as the startup disk in system preferences when you boot from 10.3 on the existing HD? If not, you're not going to see this work from the keyboard command.
  15. wainwright.ian macrumors newbie

    Sep 2, 2007
    Hello and thanks for your help!

    I can select it as the start up disk, though on boot it simply ejects the CD. I don't have the original CD:s, only the DVD, though as I have the DVD already, i felt it OK to download the CD:s. It's the same stuff, only divided, right?
  16. wainwright.ian macrumors newbie

    Sep 2, 2007
    Don't know the password.

    Oh, and by the way, my brother changed the password and does not remember it, so I can't press "install OSX" which pops up when I insert the CD. Does this change anything?
  17. wainwright.ian macrumors newbie

    Sep 2, 2007
    At: http://support.apple.com/kb/HT1395, it says 4.1.9 is the firmware to have for the Cube, i believe. Are you saying I need a later version? Nothing pops up when I press "update software", so I assume my computer is 10.3.9 up to date, or is that silly of me?
  18. sommls macrumors member

    Sep 7, 2008
    1) 4.1.9 is the correct version.

    2) Is there any chance you downloaded onto CD's a hardware-specific version of Tiger (that came with an iMac, for example)? Those don't fly for installations on other models.

    Sorry to be asking obvious, sort of trivial questions but I've erred in simple ways myself too many times to be too proud.
  19. California macrumors 68040


    Aug 21, 2004
    You probably have the cd cdrw optical drive in the Cube, no dvd.

    There were only three types of original optical drives for the Cube:

    1. CD rom only no DVD

    2. CDRW burner only no DVD

    3. DVD/CD reader only

Share This Page