Powermac G4, Help needed please.

Discussion in 'PowerPC Macs' started by cross1976, Oct 17, 2012.

  1. cross1976 macrumors newbie

    Oct 17, 2012
    Hi, i've just purchased a powermac g4 400mhz very cheap, i've tried to get it booted but no joy, its my first mac and all I know is that I get a starting chime, a grey screen with an apple, then a black screen with text that says localhost:/root#, I have tried a few different keys at start up and got to what I think is a boot screen with three tabs, on the left is a refresh tab, in the middle is a drive with an X on it, and on the right is an arrow that just takes me to the text screen with localhost:/root# ,I have also followed some instruction on reseting the PRAM & NVRAM, Any help or advice would be great.
  2. orestes1984, Oct 17, 2012
    Last edited: Oct 17, 2012

    orestes1984 macrumors 65816

    Jun 10, 2005
    You've held down the option key which brings up a list of bootable devices or an arrow to go to the normal boot sequence. If you click on the one with an X on it, it should load OS X. If that is OS X it seems like it might be booting up into single user mode.

    If you get to localhost:/root# You shouldn't be there, type "shutdown -r now" without the quotation marks and let it boot normally, you've gone into single user mode and the bash shell. There is no magic key command to get a Mac to boot it's not rocket surgery, you press the power button and it boots like any other computer.

    If it fails to boot OS X there is something going on with the install. If this is the case grab an install CD then boot holding down the C key to boot from the CD go to disk utility and run a repair disk. Failing that try a fresh install.
  3. cross1976 thread starter macrumors newbie

    Oct 17, 2012
    Still no joy.".

    Thanks for the quick reply,

    I've tried all of your suggestions but still no joy, i've just had my Panther os x delivered,
    I put the disc in, press the option key on startup, but for some reason it does not show up on the menu,,, any suggestions?
  4. Intell macrumors P6


    Jan 24, 2010
    Does the optical drive make spin up noises when the disc is put into it as if the drive is seeing what's on it? Did you click the refresh arrow on the boot menu screen? Is it a retail version of Panther?
  5. cross1976 thread starter macrumors newbie

    Oct 17, 2012
    Completely stuck......

    I noticed that the drive was only cd-rom, i've now changed it to a dvd drive, I put the panther os x install disc in but it says that bundle software cannot be installed on this computer, I put in tiger and it said something about only upgrading mille, instead of the full install,,,,,after the installation finished it restarted and went straight to the localhost:/root# screen, i'm completely stuck on this one.....
  6. 666sheep macrumors 68040


    Dec 7, 2009
    Try below commands when you'll get localhost:/root#:

    nvram boot-args=" "  <enter>
    shutdown -r now  <enter>
    or reset NVRAM in Open Firmware

    reset-nvram  <enter>
    reset-all <enter>
  7. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    What colour are your CDs/DVDs? Panther should be black and I don't remember what colour Tiger is. If yours are grey then they won't work.

    Further to this, to actually get into OF you want to hold Cmd-Opt-O-F at boot. You'll get a screen with a little text and I think it says "Welcome to Open Firmware". For good measure I run set-defaults as well:

  8. cross1976 thread starter macrumors newbie

    Oct 17, 2012
    No entry...

    I've tried all of the above suggestions, now on start up it gets to the grey apple screen with a loading dial below, then the apple changes to a no entry circle and stays on that screen.
  9. orestes1984 macrumors 65816

    Jun 10, 2005
    Tiger should also be black with a grey X, if the discs are grey they are machine specific. If you are trying to install Tiger, go through this


Share This Page