Powermac G4 will not power on. :(

Discussion in 'PowerPC Macs' started by Mactagonist, Jan 27, 2009.

  1. Mactagonist macrumors 65816

    Joined:
    Feb 5, 2008
    Location:
    NYC - Manhattan
    #1
    Currently it is almost entirely unresponsive. I came to wake it from sleep a few days ago and it refused to wake. It is totally unresponsive to the power button on the Apple Cinema display and when the power button on the front of the tower is used the button lights up blue and then goes out. There is no fan activity or other sign of life. There is no burned oder or evidence of anything charred.

    It is a dual 1.42 MDD FW800 machine with AGP graphics. Model: M8570

    So far I have:

    -Removed and reseated the graphics card, RAM and other PCI cards.

    -Removed battery and let it sit unplugged over night.

    -Performed PMU reset. (once)

    At this point I have come to believe the power supply needs to be replaced. it is model: 614-0224 (360w). After looking online they are stupidly expensive, from $180 to over $500 each.

    I will be ordering a new MB (PRAM?) battery (Saft 3.6v LS14250C) and replacing that as well.

    Questions:

    - Have I missed anything here? Is there any other explanation or method of troubleshooting I should try?

    - Is there any cheaper source for the power supplies? Why are they so absurdly expensive? Does anyone here want to give me a sweetheart deal on one?

    - Can anyone recommend a source for the LS14250C battery locally in Manhattan? Radioshack has it as an online only item and wants $15 for it.
     
  2. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #2
    It has nothing to do with the PRAM battery. Check to see if the CPU is properly seated, they come loose and will cause all sorts of issues in those models. Verify that all power connections to peripherals are tight because that causes the same issues (seen it myself on my own MDD).

    If nothing works, you most likely have a blown power supply.
     
  3. sngx1275 macrumors regular

    sngx1275

    Joined:
    Jan 27, 2009
    Location:
    Missouri
    #3
    Can anyone clairfy on whether you absolutely need a specific power supply for that? I also have a PowerMac G4.

    I know the plugs would be different, but are the voltages not the same as a regular PC? What I'm getting at is what about soldering the mac ends onto a PC power supply?
     
  4. PostTribber macrumors member

    Joined:
    Mar 13, 2007
    Location:
    Woodland, CA
    #4
    might be the burner...

    I have a 450mhz Sawtooth, which I replaced the ROM Drive with a burner way back when. one day, mine wouldn't wake also. normally you'll see a green light flashing behing the burner door as it comes up to speed. when I didn't see that, I ordered a new burner, swapped it out, and that resolved the issue.
     
  5. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #5
    Yeah that might be your best bet. Check out this page for a ATX PSU conversion for the MDD G4. Only thing you don't have is a 25v to power the ACD displays but can easily be done with another external AC adapter.

    Yeah those MDD PSU's are still ridiculously high. They even bring in money for non-working ones as there are people out there that repair them and then sell them for $200+. I just sold 2 non-working? ones on ebay and brought in $100+ for them.
     
  6. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #6
    Have you tried a direct power on test of the power supply.

    Disconnect the power supply from all of the components. Make sure it still is plugged to your power outlet though. Then use a paperclip to connect the Green 'Power On' cable to one of the black ground cables and see if the power supply turns on. If you have a voltage tester you could then test each of the lines to make sure they are operating in their specified range. Usually though if the PS turns on it is fine.

    Pinouts
    http://www.outofspec.com/frankenmac/wire.shtml
     
  7. jcook1212 macrumors newbie

    Joined:
    Jan 29, 2009
    Location:
    Ann Arbor, MI
    #7
    How I fixed my power issue

    My PowerMac G4 tower had an issue powering up about two months ago. I would press the power button, the power light would flash/glow once, but the computer wouldn't try to power up. I solved the problem by replacing the battery. In fact, I found the battery at my local RadioShack. If you're close to one, you might want to stop by and double check that they don't have the one you need.
     
  8. rusty2192 macrumors 6502a

    Joined:
    Oct 15, 2008
    Location:
    Kentucky
    #8
    power light flashes, power supply on, but no activity

    I saw this thread when my power mac G4 was experiencing a similar issue. When you press the power button, the light turns on as long as you are holding the button in. The fan on the case turns on, as does the fan on the power supply. I tested all of the outputs on the power supply and they are outputting the voltage specified.

    Does anyone know what the problem could be?
     
  9. Dave H macrumors 6502

    Dave H

    Joined:
    Mar 2, 2008
    Location:
    California
    #9
    Did you try a PMU reset?
    If so, were all the cables on the back disconnected?
    http://docs.info.apple.com/article.html?artnum=95037
    http://docs.info.apple.com/article.html?artnum=95035
     

Share This Page