Powermac G5 1.8 DP Won't Boot - Help?

Discussion in 'PowerPC Macs' started by OChrisJonesO, Mar 26, 2014.

  1. OChrisJonesO macrumors newbie

    Joined:
    Mar 26, 2014
    #1
    Firstly, I acquired a new (to me) Powermac G5 Model A1407 for free from a co-worker, who has a newer windows PC and wanted this behemoth out of her house. She originally owned an iMac G5 that was having video issues, and had some sort of an apple technician transfer her hard drive from the iMac, and put it into this Powermac. I really don't know the history of this powermac aside from that. When this was done however, it was in known working condition.

    After bringing it home, it was literally never once plugged in or used in any way. A few months later, she wanted to get rid of it, and now here we are.

    :apple: Specs:
    Powermac G5 Model A1407
    1.8Ghz Dual Processor G5
    x2 80 GB SATA Drives
    Ram: 2 sticks say 512mb, 2 are missing stickers, I would assume 2GB overall
    NVIDIA FX5200 AGP
    ATI Rage 128MB

    After taking it home thinking it was in working order, and planning to do a fresh install of leopard and have a very nice backup machine to my custom built gaming rig, it doesn't boot. Pushing the power button, the front panel white LED light comes on only when it is pushed, not when it is actually running. After pushing it on, 1 system fan revs, then another, and then all fans kick on and run normally. I can hear hard drive activity. However, there is no chime, no video out (on either the FX5200 (DVI) or the ATI Rage (VGA). After leaving running for a few minutes, the fans get REALLY loud. I am using the apple power cord, and can hear 2 clicks when plugging it in. The acrylic piece is in, and when removed, the fans go full blast and a red led on the logic board comes on.

    I have tried:
    Removing RAM dimm's, using various configurations
    Reseating both video cards, removing one and running the other
    Disconnecting both hard drives
    Resetting the PMU
    Taking out the PRAM battery (don't have a voltometer to test if it's giving 3.6v)
    -All to no avail, still no chime, no video, no boot.

    At this point what could it be? Failed power supply? Dead logic board? What else could I try? I don't want to have to buy a replacement logic board to get this to work, but I guess it is a possibility. I wouldn't get much selling on eBay in nonworking condition (and shipping would be ridiculous). I love the case and this one is in pretty good condition, it's just such a beautiful system.

    Any suggestions? Thanks in advance.
     
  2. jrsx macrumors 65816

    jrsx

    Joined:
    Nov 2, 2013
    Location:
    Tacoma, Washington
    #2
    I don't know the solution of the problem, but perhaps this will help: https://discussions.apple.com/message/5122785
    Sorry If I'm posting something you already saw. :eek:
    This seems to be a fairly common issue with PM G5s. You see it pop up a lot on the internet.
    A lot of people say it's the ambient temperature sensor not working correctly. Hope this helps.
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    I had a 1.8Ghz G5 (single CPU) PM die on me at work last year. It was replaced with the MacPro I use now and I took it home. Either it was the CPU or the logicboard because I had the same issues you describe. I replaced the logicboard (came complete with CPU and heatsink) for $60 off eBay and it booted right up. It's now back at work, but I was only out $60.

    So…as much as you may not want to hear it, it's probably either the logicboard or the CPU.

    Also note, whomever put the Rage 128 card in has no idea what they are doing. I've tried that and the Rage 128 is such an old card that the G5 refused to boot with it in. Since you mentioned you tried booting with the Rage card removed though then it has to be down what I mentioned earlier.
     
  4. tom vilsack macrumors 68000

    tom vilsack

    Joined:
    Nov 20, 2010
    Location:
    ladner cdn
    #4
    You did say you have done these but just double checking...

    -are the memory stick both same size? have you placed them in "bottom top bank" "top bottom bank"?

    http://support.apple.com/kb/HT2248

    -when you reset the PMU did you have everything unpluged and did you hold down the little button (whatever it is called) for at least 5 seconds?
     
  5. PowerMac G5 macrumors newbie

    PowerMac G5

    Joined:
    May 30, 2016
    Location:
    Australia
    #5
    I'm having the same problem on my Powermac, did you ever find out how to fix this issue.
     
  6. MacCubed macrumors 68000

    MacCubed

    Joined:
    Apr 26, 2014
    Location:
    Florida
    #6
    It is most likely the dreaded BGA RAM Slot failure. The only "real" way to fix this would be to solder a new part on or replace the board. Some people have reported success using a heat gun to relive the solder joints of the BGA RAM controller, or by reflowimg in an oven.
     

Share This Page