PowerMac G5 2.7 Dual Keeps rebooting

Discussion in 'PowerPC Macs' started by f7digital, Jun 28, 2009.

  1. f7digital macrumors newbie

    Jun 28, 2009
    I have the G5 2.7 Dual Ghz (Got this computer used a little while ago)
    This is the pre-intel (I believe nearly the last one made before the change)

    The computer has worked great for a few months until this morning.
    Now on restart it starts to boot up, but after 1-2 minutes reboots again (before ever getting to the blue screen) and this keeps happening over and over in a loop.

    I tried resetting the PRAM to no avail.
    I am suspecting something happened when my son tried to copy some music files from a thumb drive yesterday (he was unable to do so and was getting some sort of "damaged Macintosh HD" message) I didn't worry too much about it at the time.
    Also recently we've been powering down ALL our computers TVs etc. every night to save on our electric bill, so like our habit, we shut the computer down last night and this morning --- the problem began.

    I don't own a Leopard system software DVD but was wondering if I should go buy it and try a system install. Or if I should get it into a repair shop.
    Obviously I'm super concerned right now about a ton of data/files I don't want to lose.

    Thanks for any help!
  2. Dr.Pants macrumors 65816


    Jan 8, 2009
    First thing you should do with a G5 like that is the leak test - unplug everything, open it up (removing the plastic sheild) and then prop it on an angle against a bookshelf or something with the towel under it for a few hours; one does want to put it so that any liquid from the cooling system is running out of the case. Also, use a towel you don't want - stuff's corrosive.

    If you don't have any leaks, then you may have a RAM problem. Make sure that its installed in pairs in the correct configurations as described in the G5 user manual. If they are, take them out, dust them off, reseat them.

    If the problem persists (lol, I feel like Microsoft), then its most likely your hard drive (in fact, I think this is your problem to begin with, but it always helps to remove as many other things as possible). If you have a copy of Tiger, you should install it to a new hard drive and see if you can get anything off of the old one; if yes, the OS was corrupted or the hard disc was scratched or soemthing, if no, then your hard drive has failed and you need a new one and a copy of Leopard, if that is the OS you want to run.

    If you don't have a copy of Tiger, then grab a copy of Yellow Dog Linux. You may not even have to get a new hard drive - it may be a LiveCD!
  3. f7digital thread starter macrumors newbie

    Jun 28, 2009
    From bad to worse

    I randomly tried the memory idea. I found it really hard to get my 2GB of ram out and especially tough to get back in (the clips don't really go back all the way) I'm afraid I crack the mother board if I push any harder.

    Anyway I did that, tried to restart and now it doesn't even begin to boot up (no chim) -- the white light at the power button just blinks.

    What now?

  4. Dr.Pants macrumors 65816


    Jan 8, 2009
    :eek: Curses!

    Well, personally, I know the feeling - pushing too hard will break the logic board. It takes some getting used to - are you sure you seated the ram all the way in the slot? No POST tells me memory may not be in there correctly....

    On my G5, a quad (may be slightly ddifferent) there is a clicking sound as the momery seats itself all the way in. The ejectors on the sides of the memory slot have to be OPEN when you put your RAM in - they will snap closed when the RAM is seated.

    Check it from Apple. In the diagrams, J11 has to match J12, J13 has to match J14, etc.

Share This Page