Powermac G5 died...

Discussion in 'PowerPC Macs' started by tonyeck, Jul 28, 2008.

  1. tonyeck macrumors 6502

    tonyeck

    Joined:
    Sep 3, 2004
    Location:
    Las Vegas, NV
    #1
    Ok, recently my G5 (dual 2ghz, September 2004 model) made a bit of a pop and the power shut off.

    There is now no power at all to the machine... at all. No blue light, no noise, nothing. Obviously the PSU has died. I also have a dual 1.8ghz G5 (late 2004) that has a dead logic board :)rolleyes::rolleyes::rolleyes:)...

    Any one know off the top of their head if their PSU's have the same output/wattage before I start hacking away at the heatsinks?
     
  2. zmttoxics macrumors 65816

    zmttoxics

    Joined:
    May 20, 2008
    #3
    Sounds like your house has some electrical gremlins. :p

    The swap should be OK. I believe all of the same year variations came with the same basic parts. So 2004 == 2004 but 2004 != 2005 kindof stuff.

    Good Luck!

    PS: I recommend putting it on a solid APC UPS if you haven't already. :D
     
  3. tonyeck thread starter macrumors 6502

    tonyeck

    Joined:
    Sep 3, 2004
    Location:
    Las Vegas, NV
    #4
    I have it running on a pretty good APC UPS which is about 3 years old now...

    It all just sucks!
     
  4. zmttoxics macrumors 65816

    zmttoxics

    Joined:
    May 20, 2008
    #5
    3 years is about near end life. Might want to look into replacing it anyways. Batteries don't live for ever.
     

Share This Page