PowerMac G5 Dual 2.0 Chimes but no video

Discussion in 'PowerPC Macs' started by hackerwayne, May 14, 2012.

  1. hackerwayne macrumors 6502a

    hackerwayne

    Joined:
    Feb 17, 2012
    Location:
    Kuala Lumpur, Malaysia
    #1
    Hi all :)

    Just received a old PowerPC G5 2.0GHz Dual Processor. When i tried to power it on, the Power LED came on as usual and the G5 chimes, but it didnt display any video on the screen. :( None of the diagnostic lights display red, heres what i've done

    - Reseated all the RAMs
    - Pressed the PMU button
    - Tried CMD+Option+P+R but didn't hear a second chime
    - Swapped a good working graphics card
    - Swapped a good working display with good DVI-D cable
    - Tried CMD+Option+O+F my LCD idle light flashes from amber to green but after 2 sec back to amber (idle)
    - Tried holding down power button for 5 sec and heard a tone sound + LED light flashes
    - When i took the plastic cover off 1 Diagnostic LED turns red and the fan starts to run at full speed (which is normal)
    - The fan runs at normal speed if the plastic cover is in place.
    - HDD is detached but same issue when the HDD is in place.

    Not sure if the internal CMOS battery is still good, but i don't think it will cause such issue right?
     
  2. photonorm macrumors member

    Joined:
    Mar 2, 2011
    Location:
    Memphis, TN
    #2
    overheating?

    Are there any other LED lights deeper into the computer that you can see on when you are looking into it from the front? There is a LED that will come on when the processors are too hot. I am experiencing the same symptoms you are. However, I am working with a Dual 2.5 that is liquid cooled. I just did my second rebuild of the LCS and I can't get past the chimes and the overheat LED comes on.
    If your machine is liquid cooled check for any coolant leaks.
    I look forward to your future postings as we might be in the same boat.

    You can read about my original situation at http://forums.macrumors.com/showthread.php?t=1109014

    -Norm
     
  3. havokalien macrumors 6502a

    havokalien

    Joined:
    Apr 27, 2006
    Location:
    Kelso, Wa
    #3
    2.0 not liquid cooled

    Try unscrewing and switching the processors. If it boots then one of the processors is dead. You will need ASD 2.5.8. Email me and I can help you there, I may even have a spare processor.
     
  4. hackerwayne thread starter macrumors 6502a

    hackerwayne

    Joined:
    Feb 17, 2012
    Location:
    Kuala Lumpur, Malaysia
    #4
    Thanks for the heads up, no over temp LED lights up. Everything is absolutely normal (Chimes, does PMU reset) except no display and doesn't do PRAM reset

    ----------

    I do have some spare 2.3GHz processor around. (My side line is to repair, refurb and resell used/old Macs), not sure if they are compatible, but when i plug it in, Processor A and B Over Temp message came on (at this point, im 70% sure they arent compatible) but when i switch the 2.0 back, no LED lights up. Tried removing A and let B runs, vice versa. No dice. Currently the unit is still in my store room so i can do any kinds of test.
     

Share This Page