PowerMac G5 freezing

Discussion in 'PowerPC Macs' started by Graveyard, Apr 9, 2013.

  1. Graveyard macrumors regular

    Jul 29, 2009
    A friend of mine bought a dual cpu G5 a few years ago. It worked fine until a few days ago. It powers up, you can hear the chime, but it only displays image when it wants to. And when you get the boot screen, it freezes up right after the apple logo shows up on the screen. I've checked all 8 memory modules and the hard drives. All of them are in perfect working condition. The pram battery on the other hand is dead. Before this happened, he told me he got a kernel panic. It worked ok again after rebooting the machine for another day. Then he got an error relating to cpu1 from what i could see from the picture he took of the screen on his telephone. Could it be a problem related to the first cpu? My thoughts go to a psu problem from my past experience.
    It's a dual cpu 2GHz G5, 4GB ddr1, 2x160 GB hdd, fx5200.
    Any help is apreciated. I don't want to start disassembling the thing to get to the psu for nothing.
  2. seveej macrumors 6502a


    Dec 14, 2009
    Helsinki, Finland

    if the user gets an error message regarding a CPU, then that might be the probable culprit.
    OTOH, these types of errors (assuming the error message is incorrect) can also be produced by memory, logic board (bad) and GPU (all of which Apple Hardware Test should be able to spot.

    The PSU (although they are notorious) should not produce these types of symptoms. PSU symptoms are usually either sporadic (may happen at any time, and not as regularly) or catastrophic (no chime).

  3. Graveyard thread starter macrumors regular

    Jul 29, 2009
    Well it doesn't play the chime all the time. That's what led me to think it may be a psu problem. I have tried booting from dvd and it gets stuck right after the apple logo appears on the screen, exactly like it does when i let it boot off the hdd.
  4. Nameci macrumors 68000


    Oct 29, 2010
    The Philippines...
    It is on the process of booting and got stuck.

    I would suggest firing up console and look for the messages where it stopped.

Share This Page