PowerMac won't boot

Discussion in 'PowerPC Macs' started by numark, Apr 1, 2006.

  1. numark macrumors member

    Jul 24, 2004
    Buffalo, NY
    I have one of the late-2004 PowerMac G5s, and a few days ago I was working on it, went to go shut it down, and everything just froze. I could hear the hard drive clicking, so I hit the power. Rebooting (yes, I know I shouldn't be doing this with a failed hard drive) only gave me the multi-language error screen asking me to restart.

    I bought a new SATA drive today and replaced the old one. I put the OS X install disc into my drive, and started it up. Now, I get the standard icon that briefly appears when it can't find OS X, but then it goes to the standard boot screen, thrashes the CD around a bit, then asks me to reset again. It also doesn't seem to detect my keyboard or mouse (wireless both) so I can't eject the disc or zap the PROM. I tried reseating the memory, having only two sticks in at a time (normally I have four), etc. and it still doesn't work. Does anyone have any ideas on what I might try next?
  2. eva01 macrumors 601


    Feb 22, 2005
    Gah! Plymouth
    have you stopped using the wireless keyboard and mouse and used wired ones?

Share This Page