"PowerPC not supported" error Lion-ready apps.

Discussion in 'Mac OS X Lion (10.7)' started by kevl, Jul 27, 2011.

  1. kevl macrumors newbie

    Jul 27, 2011
    after upgrading to Lion i had to download updates for a few of my applications–no big deal. but 2 programs that i use pretty frequently are driving me crazy as nobody seems to be having the same issue... and the devs aren't being helpful.

    Playback (Lion-ready version): You can't open the application Playback because PowerPC applications are no longer supported.

    VisualHub (the latest Lion-ready version): You can't open the application avimerge because PowerPC applications are no longer supported.
    (this one mentions avimerge because i'm trying to stitch two .AVI files together and it gives this error, then fails at the final step)

    i've repaired permissions, ran verify disk and it came up clean, used CleanMyMac to clear up caches and useless files (not UBs or Language files though). no luck.

    any guesses?
  2. Sky Blue Guest

    Sky Blue

    Jan 8, 2005
    pretty sure VisualHub became obsolete years ago, how do you have a Lion ready version?
  3. kevl thread starter macrumors newbie

    Jul 27, 2011
    you just go to techspansion.com and download the Lion patch. the newest 1.35 (1.34.1a) is Lion ready. but it's being an ******* when it comes to merging to .AVIs.
  4. Intell macrumors P6


    Jan 24, 2010
    Because the avimerge binary is PPC. You have to recompile to be universal and replace VisualHub's internal version.
  5. kevl thread starter macrumors newbie

    Jul 27, 2011
    well that makes sense. so avimerge is out, i'll have to find an updated version or a complete alternative to visualhub (noooo!!!).

    but what the heck is up with Yazsoft's Playback then? fully supported, runs on Lion, and nobody else has this problem. i've used AppCleaner to remove it before reinstalling it so i doubt there's any remnants of an older version.
  6. iThinkergoiMac macrumors 68030

    Jan 20, 2010
    In before GGJ's wrath against programs like AppCleaner.

    Small remnant files shouldn't be an issue. Have you tried running the same exact copy you have on a different Intel Mac? Even if it's just running Snow Leopard, if you get info on it it will tell you if it's PPC-native or a Universal Binary. That should clear up the issue.
  7. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Mar 2, 2010
    The AVI file format is an obsolete file format (1992, Microsoft RIFF). Use modern A/V file formats, like MP4 or MKV, which support extended features (metadata, subtitles, color information, and so on).
  8. gforshaw macrumors newbie

    Aug 4, 2011
    Kevl, to answer one part of your post - to fix Visualhub:

    1) Download ffmpegX
    2) Right click on ffmpegX and show package contents.
    3) Navigate to Contents/Resources and copy the file "avimerge"
    4) Go to the VisualHub app, right click and show package contents.
    5) Navigate to Contents/Resources and paste the file "avimerge", overwriting the old one.

    This appears to have worked for me so far with this old, but still unbeaten, great little application.

    Good luck and hope this helps.

    With all due respect Mr. Retrofire, do you really think this kind of answer is helpful?
    It does not address the original posters question at all and just comes across as condescending.

    Do you think we don't know about MP4s or MKVs already?
    It may shock or surprise you up there in your tower of technological superiority, but some people actually still use AVIs for various reasons and are quite happy with them.

    Just like some of us still use VisualHub despite the vast amount of newer, supposedly superior Mac video converters.

    I'm sorry, but that type of unhelpful, patronising reply just gets on my nerves.
  9. Mac Fly (film) macrumors 65816

    Mac Fly (film)

    Feb 12, 2006

    I love you ; )
  10. deebster macrumors 6502

    Oct 21, 2004
    Olde Englande
  11. FastangV6, Sep 18, 2011
    Last edited: Sep 18, 2011

    FastangV6 macrumors regular


    Oct 1, 2007
    +1 Thank you for this.

    I also used this exact same fix on a different app called D-Vision 3 that was my previous favorite/fastest .avi merge tool.
  12. InuNacho macrumors 65816


    Apr 24, 2008
    In that one place
    Maybe the OP is merging old AVIs together or has a camera that only shoots AVIs.
  13. kevl thread starter macrumors newbie

    Jul 27, 2011

    this has resolved the issue for me as well. unfortunately the issue with Playback still persists, even after updating through 3 "lion ready" versions now. oh well, can't win them all. thank you gforshaw!

Share This Page