PPC G5 Tower won't boot, no chime, gray apple screen

Discussion in 'PowerPC Macs' started by jhnhth, Jun 25, 2010.

  1. jhnhth macrumors newbie

    Jun 24, 2010
    I've read everything I can find on this - thanks to everyone on this site for posting such useful info - but I have not gotten it sorted yet.

    Here's the deal:

    Early 2005 G5 Tower, 2.0 ghz DP - left unplugged for a few months. Will not boot. No chime. No flashing light (light is steady when "on") Will not progress past the gray Apple screen. Left on, the fans go crazy after five minutes and I power it down.

    It will not safe boot, will not boot from commercial Leopard disk, will not boot from original disk (disk1) .... BUT will boot from Apple Hardware Test (disk 2). Hardware Test finds no problems.

    I replaced the battery. Reset PMU button (pressed only once, waiting 10 sec) still won't boot.

    RAM is good, tested on another machine using rember.

    Will boot in Open Firmware, but I don't know what to do with this.... If I leave open firmware open for 15 minutes, it freezes up and I have to power down.

    Reading this helpful forum makes me think it might be the logic board, even though it passed Apple Hardware Test.

    Any suggestions you guys can make?

    Thanks in advance.

  2. kbfr08 macrumors 6502

    Mar 16, 2007
    I just had this problem with my dual 1.8GHz. Hold the front power button until you hear a long beep, then go to open firmware and type

    If that doesn't work, do three pram resets.
  3. jhnhth thread starter macrumors newbie

    Jun 24, 2010

    Thanks for the advice - I got to OF, the first two commands were ok but on the third it just froze up.

    I zapped the pram but there is no chime, so I kind of had to go by feel.

    I ran ASD 2.5.8 and it passed, but when I clicked "restart" it froze. The ASD disk is only the second disk I can start up off of, btw, along with Apple Hardware Test.

    Thanks again for your post - even though my problem persists, I really appreciate your help!
  4. kbfr08 macrumors 6502

    Mar 16, 2007
  5. jhnhth thread starter macrumors newbie

    Jun 24, 2010
    Thanks again

    Thanks again for your further advice. I'm printing out the guide and will read it over the weekend so maybe I can tackle it Monday morning. It does look like a bit of an undertaking....

    Strangely, this is a really clean machine. I have 5 other G5, all roughly the same age, and this one is practically pristine inside. An offsite worker had it for a few years before returning it to us - it's never been used in my office.

    Even though it looks pretty clean I am going to take up the course of action you've suggested. Thanks again for your help.
  6. Apple2 macrumors member


    Feb 28, 2010
    Providence, RI
    I had the same problem with my G5. To fix it, do two things. First, replace the motherboard battery. It's located near the PCI cards. Then, follow these instructions to reset the RAM:

    Hold down COMMAND, OPTION, O, F on boot to enter open firmware. After it finishes loading, type these commands - return after each.


    After this, your G5 will restart and should boot normally. It worked for me.
  7. jhnhth thread starter macrumors newbie

    Jun 24, 2010
    Thanks but...

    Thanks but I already replaced the battery. I am just about resigned to taking the more invasive approach and dealing with the heat sinks.... will advise of any progress.
  8. bizzle macrumors 6502a

    Jun 29, 2008
    Start pulling out parts. Start with any expansion cards and the bare minimum RAM.
  9. kbfr08 macrumors 6502

    Mar 16, 2007
    Just rebuilt my G5, it's a pretty easy process.
    If you don't have a long T10 screwdriver, buy a husky 7(iirc)-in-1 torx driver, take the T10 bit out and use a lot of duct tape to secure it to any other long screwdriver.
  10. RobMW macrumors newbie

    Aug 22, 2011
    Brisbane, Australia
    I hate to sayit but "Me Too"

    I inherited a G5 tower from a research group upstairs and it was running fine. I had to install 10.5 to allow me to use iMovie as we wanted it to sit there and crunch video for us.
    After the 10.5 was installed from the Black Universal disk it did an update and tried to restart.
    Nothing. Dead as a dodo. Not even any start up chime. No keyboard recognition as far as I can see. capslock light does not turn on.

    I have tried absolutely everything from multiple forums and it is about to become a very expensive doorstop. Such a waste.

    I cant even get to any boot screen.

    Coincidental hardware failure just seems... well to coincidental, considering the number of other people this has happened to after a 10.5 update.

    BTW to get the Instal DVD out of the optical drive I had to pull out the drive unplug the ribbon cable and hit the eject button.

Share This Page