[PPC] I can't install Xcode after a failed install

Discussion in 'Mac Apps and Mac App Store' started by GameX, May 29, 2014.

  1. GameX macrumors newbie

    Joined:
    May 27, 2014
    #1
    Hi,


    I wanted to install Xcode on my PowerPC, with Tiger 10.4.11, I did suceeded once, before I formatted the drive.
    I use the DMG "xcode25_8m2558_developerdvd.dmg".

    The problem is that I started the installation last night, the install taking usually from 1 to 2 hours (It's a G3), before go to sleep.
    I did not changed the energy settings, as I thought the Mac wouldn't go to Sleep Mode during the installation.
    I was wrong, when I got up this morning, the Mac was sleeping, when I turned it back on, I had a popup saying that the installator crashed.

    I tried reinstalling Xcode from the DMG, but I always have a message "Errors occurred during the installation, plese retry".
    I cannot seems to uninstalled it, because it's not in the "Applications" folder.

    I tried the command here, with no effect:
    sudo /Developer/Library/uninstall-devtools --mode=all

    http://osxdaily.com/2012/02/20/uninstall-xcode/

    I then wiped the Developper folder with a sudo rm -rf (Don't know if I should have), rebooted, and tried to install it again. I got the same error message (But now, the "Developper" folder is back).

    What shoud I do, to completely uninstall it, then do a succesful install?

    Thank you
     
  2. Intelligent, May 29, 2014
    Last edited: May 29, 2014

    Intelligent macrumors 6502a

    Intelligent

    Joined:
    Aug 7, 2013
    #2
    Do you have the cd? I would suggest deleting everything and reinstalling again. Just search for xcode and delete its files, but look first so that you dont delete anything wrong. Also did you install it on the boot drive? You have to do that with the 10.3 (Panther) Xcode 1.0 version. And it should not be in the "Applications" Folder its on /hd/Developer/Applications/Xcode.
     
  3. GameX, May 29, 2014
    Last edited: May 29, 2014

    GameX thread starter macrumors newbie

    Joined:
    May 27, 2014
    #3
    Yes, it's installed on the boot drive, the Tiger partition.

    All I have is a Xcode DMG, but I also have the Tiger installation DVD (I would like to avoid reinstalling Tiger again).
    You would suggest, open the Xcode DMG, check the files, and try to find all these files in my Tiger drive?
    The Xcode app is not present in the Applications folder at all.

    Thanks for your help

    EDIT: I'll check out the Developper folder more closely. Maybe will wipe the folder again, while I did tried it once, rebooted, and same problem.
    Will try that again.

    EDIT 2 : Oh, it look installed on the /Developer/Applications folder, actually, I can run it!
    It's akwards, why the installer always seems to get an error, however, even when the Developer folder doesn't exists.
    I don't know if that would cause a problem or not.

    I think I got mistaken, because on a Intel Mac, last time I checked, Xcode was in /Applications/Utilities (4.6.3, that makes sense).
     

Share This Page