PPC Mac Mini Issue

Discussion in 'Mac mini' started by Roy Hobbs, Mar 13, 2008.

  1. Roy Hobbs macrumors 68000

    Roy Hobbs

    Apr 29, 2005
    My mother-in-laws Power PC Mac Mini stopped working the other day.
    After booting to disk utility and seeing that there wasn't a hard drive mounting I assumed the hard drive was dead.

    I ordered a replacement from OWC, opened the mini, and put in the new hard drive. Now I can't get the mini to boot from CD all I get is a blank gray screen and eventually the folder with a question mark icon.

    Any idea?? I was under the assumption I could boot to disc again, format and reinstall on the new hard drive. I also can't get the CD to eject but it is spinning up .

    Any ideas??
  2. Roy Hobbs thread starter macrumors 68000

    Roy Hobbs

    Apr 29, 2005
  3. Zygon Gambit macrumors regular

    May 21, 2006
    Maybe it's not the hard drive that's broken...? Could you test the one you removed somewhere else?
  4. Lord Zedd macrumors 6502a

    Lord Zedd

    Oct 24, 2007
    Denver, Colorado
    Boot holding the C on the keyboard, if that does not work boot holding the option button and select the CD.
  5. Roy Hobbs thread starter macrumors 68000

    Roy Hobbs

    Apr 29, 2005
    Yes, the drive is dead....I put it in a external enclosure and Disk Utility did not recognize it nor did it spin up.
  6. Roy Hobbs thread starter macrumors 68000

    Roy Hobbs

    Apr 29, 2005
    Neither of these work.....for some reason it doesnt want to boot from the CD. I can here it spinning up but it always tries to boot from the blank hard drive.

    I think I may slap the new drive in the external enclosure and try to install OS X on it from a different mac
  7. ADent macrumors 6502a

    Sep 9, 2007
    You can try to hold option down when booting.

    You can try putting the drive in an external case. If that doesn't work disconnect drive, boot from CD . Then connect the external drive.
  8. harixvirex macrumors newbie

    Jul 15, 2008
    Mac Mini Gray Screen - A solution which works at last


    Atlast having tried a lot of options but invain..... Here is one thing which worked after

    1) Tried booting from CD and "C" key holding - NO GO!!
    2) Tried to perform a Network boot - NO GO!!
    3) Tried to perform a Target Disk mode to reset MBR record using the Firewire cable and "T" key - NO GO!!
    4) Tried to zapp PRAM by Apple+Optio+P+R ~ NO GO!!
    5) Tried to reset only NVRAM by Apple+Optio+O+F ~ NO GO!!

    At last....2 commands one after the other help me

    1) Boot into Open Firmware using Apple+Optio+O+F
    2) Type "reset-nvram"
    3) Type "reset-all"

    without the quotes....

    Then i got a and the machine started booting into Leopard / Tiger.....

    Was sucessful with 3 mac mini machine......


    Hari S

Share This Page