PPC MDD - No Internet Via Ethernet

Discussion in 'PowerPC Macs' started by BWCDoc, Oct 30, 2012.

  1. BWCDoc macrumors newbie

    Jul 6, 2011
    My problem is that I cannot access the internet via my ethernet port and that I must unplug the power cord to get my computer to boot.

    Power PC G4 Mirror Drive Door
    OS 10.5.8
    80 GB IBM HD (original to the computer)
    6 GB Quantum Fireball HD (transferred from my old iMac)
    Plextor DVDR (replacement for non-functioning Super Drive)
    Belkin USB 2 card (to connect 2TB external Western Digital HD - currently WD HD is disconnected)
    Brother HL2240D Laser Printer (connected to USB 2 card)
    1,792 MB memory
    Westell model 6100F DSL Modem
    PC24-H AirPort Card (I don't have wireless service)

    My problem began when I was unable to start my computer. I thought that the plug might have been knocked loose and after vigorously jiggling it, the computer started. Even after replacing the power strip, this continued every time that I wanted to start the computer until I realized that the act of unplugging the power cord while jiggling it was allowing the computer to boot. From then on, I would simply reach behind the tower and briefly unplug the cord whenever I wanted to power up the computer.

    This procedure continued for about a week until pressing the power button caused the power light to go on but it would then go out when the button was released. Discussing this problem with friends lead me to conclude that the battery was probably bad. I replaced the battery but it did not solve the problem. I don't remember exactly what remedied the problem but it was either resetting the PRAM or resetting the PMU. Nonetheless, I still had to unplug the computer to get it to start.

    The next problem that occurred was that I was unable to access the internet. After much testing of the DSL connection by Verizon internet customer service, we were unable to ascertain what was causing the problem. Fortunately, I had access to a MacBook and I connected it to the modem to verify that the cable, DSL modem and its connections were working. After searching several user's groups, I stumbled upon a posting from someone who believed that resetting the PRAM five times would also reset hardware problems. I tried this and amazingly, it worked; internet access was restored. I did not shut down my computer for about a week and a half but while watching some online videos, I had a kernal crash - this is a problem that this machine has always had with videos. When I rebooted, I was unable to access the internet and, despite many attempts to correct the problem, I have not been able to fix it.

    I believe that the problem is with the ethernet port. I get a IP address instead of the normal address. I have tried resetting the PRAM singly and five and six consecutive times. I have reset the PMU multiple times in conjunction with and independent of resetting the PRAM. I have inserted and removed the battery multiple times. I have tested the new battery with my volt-ohm meter - it and the original are both fully charged. I have disconnected the USB 2 card. It may or may not be related but I must still unplug the power cord after almost every shut down in order to get the computer to boot.

    Since loss of my ethernet connection occurred once before and I was able to get it to work, I hope that this is a temporary problem and that you can help me resolve it. Do you have any suggestions? I really appreciate the time and effort that this problem will take. Thanks.
  2. eyoungren, Oct 30, 2012
    Last edited: Oct 30, 2012

    eyoungren macrumors Core


    Aug 31, 2011
    ten-zero-eleven-zero-zero by zero-two
    I'm not an electrical expert so the only thing your power problem suggests to me is the power supply. Others here know far more about that than I, so I'll just try to address your internet issue.

    As a general check, open up System Preferences and go to the Security preference pane. Click on Firewall. Is your system set at "Set Access for Specific Services and Applications"?

    If so, do this. Unplug your ethernet cable and switch the preference to either allow all aincoming connections or allow only essential services. Click OK and plug your ethernet cable back in. Open up System Preferences again and go to your Network tab. If your status does not say connected (it will probably say Self Assigned IP Address if it's not connected) then click on the Advanced button, go to the TCP/IP tab and click on Renew IP Address.

    If you get a valid IP then you have fallen victim to a known Leopard firewall bug. You can switch the firewall back to the strict security once you get a valid connection. 169.xxx.xxx.xxx by the way is a Self Assigned IP address.

    You can also add the system services MDNSRspndr and DHCP and a few others I have to lookup to the firewall exceptions so that you don't have to do this all the time or use a lower security. Those services reside in the hidden file system.

    You reset the PRAM at one point which can reset the firewall settings. It may not have done that this time (if this is the problem) because files were open when you kernal panicked. That can cause permissions errors on the open files (some of which would be your network connection files). I am just speculating, I don't know.

    If this was your problem then I'll go look that up for you. If not, then maybe someone else knows something.
  3. BWCDoc thread starter macrumors newbie

    Jul 6, 2011

    I went to the Security Panel and changed the Firewall setting from Allow Only Essential Services to Allow All Incoming Connections, reconnected the ethernet cable and was promptly back on-line!

    It is wonderful that there are people such as you who not only understand questions such as mine but who take the time to answer them. Thank-you very much.

    I don't know what is causing the intermittent start-up problem but, if I have to, I can live with it.

    Thanks again,
  4. eyoungren, Oct 30, 2012
    Last edited: Oct 30, 2012

    eyoungren macrumors Core


    Aug 31, 2011
    ten-zero-eleven-zero-zero by zero-two
    Glad I could help. Of course while searching for the relevant information I can't find things again and I didn't have bookmarks.

    Anyway, here is what I did based on the info I gathered.

    Inside /usr/sbin are the following system services:

    You can get to that folder by using the Go To Folder command from the Go menu in the Finder. After that it's a simple matter of dragging those services into the add window for the firewall.

    Doing this allows you to keep the firewall on. mDNSResponder is the biggie though. Block that and you have no internet.

    You can also reset the firewall by deleting com.apple.alf.plist which is in Library/Preferences. Restart. You will have to confirm every program seeking access to the internet once again if using the strictest firewall setting.

    Also in looking around today for this stuff there seems to be some info that indicate this problem can happen if the time and dates are wrong and/or permissions on mDNSResponder and configd.

    Doing what I mentioned previously, while it resolves the matter immediately leaves you wide open, unless you set the firewall back.

    I have discovered since I first encountered this that there is a plethora of users out there who have had this problem ever since Leopard was introduced. I beat my head against the wall trying to solve this for four hours one night with my wife's Mac until I found the first solution I gave you. It kept coming back for me until I physically added the services to the firewall exceptions (because I want firewall protection) and that problem is how I found out about adding the services to the firewall.

    So, you have options.

    Hope someone can help you out with the electrical problem. My dad was an electrical engineer in the aerospace industry during the 80s, but other than how not to kill myself I pretty much am clueless when it comes to much more than switches and sockets!
  5. cocacolakid macrumors 65816


    Dec 18, 2010
    eyoungren is on the right track with the power supply. My 1.42 GHz MDD had the same issue, first it began only wanting to start up after I had unplugged and replugged it in. A few weeks later it started to freeze up at random times, and finally would freeze after 15 mins or less of being on. It was the power supply, and putting a new one in fixed all of the problems. Two years later it's still in use every day and working great.
  6. BrianBaughn macrumors 603


    Feb 13, 2011
    Baltimore, Maryland
    I don't know what the cheapest price is for a MDD PS these days but I suspect you should consider retiring that machine. If it's $200, that's 1/3 the way to a new Mac Mini.
  7. cocacolakid macrumors 65816


    Dec 18, 2010
    I think a PS these days is around $100 or more. When I bought mine a couple of years ago it arrived with the faulty PS. The previous owner ran the IT department of a school and sent me a different working PS that I swapped out, so I didn't have to pay for a new PS.

    It is a tough choice, whether to put more money into such an old machine. The other option is for the OP to see if they can find an inexpensive working model to scavenge for parts. The parts are worth far more than the machines since users want to keep theirs going and prospective 'new owners' don't want such an old machine. I see the MDD on Craigslist here in the Chicago area a few times a year, most of the time they are $100 or less, but I know every market is different.

Share This Page