PRAM battery or battery

Discussion in 'PowerPC Macs' started by Tozier9, Mar 2, 2013.

  1. Tozier9 macrumors newbie

    Joined:
    Jan 16, 2009
    #1
    Powerbook g4 17 inch aluminum...


    So the problem is I can not start up the mac....most of the time.

    Many symptoms....

    I will try and try and occasionally it will start up.

    So I recently got a new charger since my old one died. I am almost positive this is working. However when it is plugged in sometimes it says it is charging and sometime it says it is not plugged in. The charge will go all to 0% and then my computer will stay on for as long as it wants. So for some reason it thinks it is not plugged in.

    Battery I think is almost dead, this could be the issue, however I thought the computer could still run without it.

    Now I thought the dc-inboard was bad because I had a new charger but the computer said it was not charging. So I just replaced that and the wires and put everything back together and it started up. However I put the computer to sleep and closed it. I went back to use it and nothing would happen. I tried all buttons, holding the power button to see if it would shut down, but I had to unplug it and take the battery out for it to shut down. I got it to start up one more time but it still said the battery was not charging and it was running slow.


    Also note that both times I turned it back on the date was reset to 1969...

    I have tried resetting pram but I can't get the computer back on so that is not working.

    Thoughts? I could just order a used pram battery off ebay or start with just a normal battery.
     
  2. AlbertEinstein macrumors regular

    AlbertEinstein

    Joined:
    Jan 3, 2013
    #2
    Both the PRAM and battery seem rather dead, but that shouldnt affect your computers capability to function.

    This could be a problem with the logic board. Have fun replacing things!
     
  3. Tozier9 thread starter macrumors newbie

    Joined:
    Jan 16, 2009
    #3
    Can you think of any ways to test these problems so I don't just buy random items and guess?
     
  4. SadChief, Mar 5, 2013
    Last edited: Mar 5, 2013

    SadChief macrumors regular

    SadChief

    Joined:
    Jan 15, 2010
    Location:
    Montpellier, France
    #4
    I had exactly the same problem with my PB. It was definitely gone after purchasing a (no-name) new battery.
    This is my experience with it.
    Edit : never changed the PRAM battery (it still works).
     
  5. Tozier9 thread starter macrumors newbie

    Joined:
    Jan 16, 2009
    #5
    Thanks, I need a new battery anyways so I can start there.
     

Share This Page