PRAM keeps resetting by itself

Discussion in 'Mac Pro' started by alphaod, Feb 27, 2010.

  1. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #1
    I recently had a small USB issue, so I reset my PRAM which fixed it.

    Now every time I boot the PRAM will reset itself. This particularly annoying because:
    1) It takes longer to boot as it restarts again and again (sometimes 3-4 times).
    2) I have the boot volume set to 0 and when the PRAM is reset it will go back to default which isn't fun [and it loud].
    3) I have verbose mode on and a PRAM reset removes that as well, so I need to do the 2-finger combo [which on the bluetooth keyboard doesn't work half the time].

    I can't seem to fix it. I've done all the usual things (ie: manual PRAM reset with 4-finger combo, SMC reset, reseating hardware, disconnection hardware) and I've also gone ahead and installed OS X on a new volume for testing. Nothing is working and this getting a little frustrating.

    I try not to restart my computer, but recently I've needed to it a couple times. Apple Support doesn't know what to do and they're reluctant to send a on-site tech because they're not sure what the issue is. They want me to take my computer to the Apple Store, but (1) I don't have a car, (2) it's windy and snowing like crazy outside so there is no way I'm walking a mile to the Apple Store carrying the Mac Pro by hand, and (3) even if it was sunny outside my computer weighs a lot.

    Anyone know what's going on here? The computer passes all hardware tests and disk scans reveal no bad sectors.
     
  2. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #2
    Hi,
    maybe it seems to be a "blind shot", but try to replace battery on the logic board. You can try diag button and look especially at EFI LED while starting and reebooting.
    Which rev of Mac Pro it is? Have any flashed graphic card?
    maybe write little more about your setup...

    What was that USB issue? Something wrong with onboard controller or with external device? Maybe this is the clue?
     
  3. alphaod thread starter macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    USB issue: Whenever a USB device not plugged in during boot was plugged in after boot, it would cause all other USB devices to stop working. This happened with both the rear ports, front ports, and an expansion card.

    Specs are:
    2009 Mac Pro
    2x2.66GHz 8-core "Gainestown"
    12GB RAM (Apple OEM)
    GTX285 Mac Edition (EVGA original—not flashed)
    4x300GB VelociRaptor RAID5 with Areca ARC-1212
    FirmTek SeriTek/2ME4-E eSATA card
    Sonnet Tech Allegro USB PCIe

    I've pulled all expansion cards and even changed video cards to test and nothing has fixed it. I've pulled RAM out and tried different configurations as well.
     

Share This Page