Pre-scroll lag from touchpad for 2019 MacBook Pro

ralliart12

macrumors newbie
Original poster
Jun 29, 2010
5
1
Hi fellows. Anybody observed (in your MacBook Pro) that, if the machine is left to idle for a while, that there will be a lag from the first moment the scroll is physically administered onto the touchpad, and when the document/webpage reaches the location it is supposed to scroll till? But after that first scroll, there is no lag whatsoever.

Example: first scroll after machine idle, the cursor has to "jerkily catch up" to the location in the page where it is supposed to scroll to, instead of "gradually" gliding to that spot. See 0:03s, 0:28s, 0:46s(observe my fingers' movement on the touchpad and how the page jumps):

This happens across browsers (MacBook Pro 13” 2019, macOS 10.14 Mojave). May I know how I can rectify this?
 

x-evil-x

macrumors 601
Jul 13, 2008
4,483
2,222
its because you have the keyboard backlight on probably 5 second "turn off" thats its doing that. Change that and should be fine.
[doublepost=1561285469][/doublepost]
Hi fellows. Anybody observed (in your MacBook Pro) that, if the machine is left to idle for a while, that there will be a lag from the first moment the scroll is physically administered onto the touchpad, and when the document/webpage reaches the location it is supposed to scroll till? But after that first scroll, there is no lag whatsoever.

Example: first scroll after machine idle, the cursor has to "jerkily catch up" to the location in the page where it is supposed to scroll to, instead of "gradually" gliding to that spot. See 0:03s, 0:28s, 0:46s(observe my fingers' movement on the touchpad and how the page jumps):

This happens across browsers (MacBook Pro 13” 2019, macOS 10.14 Mojave). May I know how I can rectify this?
yup just tested it. turn it higher if you dont want it to lag when the keyboard turns back on. Whats it currently set at?
 

ralliart12

macrumors newbie
Original poster
Jun 29, 2010
5
1
its because you have the keyboard backlight on probably 5 second "turn off" thats its doing that. Change that and should be fine.
[doublepost=1561285469][/doublepost]
yup just tested it. turn it higher if you dont want it to lag when the keyboard turns back on. Whats it currently set at?
But shouldn’t it be unacceptable that a basic hardware feature causes system unresponsiveness?

Had tried increasing it to 10s but as you’d indicated, the pre-scroll lag occurs when the keyboard is re-awaken. I suspect it doesn’t matter how long I adjust the keyboard “sleep” time...
 

x-evil-x

macrumors 601
Jul 13, 2008
4,483
2,222
But shouldn’t it be unacceptable that a basic hardware feature causes system unresponsiveness?

Had tried increasing it to 10s but as you’d indicated, the pre-scroll lag occurs when the keyboard is re-awaken. I suspect it doesn’t matter how long I adjust the keyboard “sleep” time...
it is what it is. its just the system making sure you are using the keyboard again before lighting up and turning back on. Its basically going into sleep mode. You can toggle it off in keyboard settings if you want.