Preparing for SSD in MBP

Discussion in 'MacBook Pro' started by tofagerl, Nov 15, 2009.

  1. tofagerl macrumors 6502a

    tofagerl

    Joined:
    May 16, 2006
    #1
    I am using an optibay-ish thing to put an OCZ Vertex in the Superdrive slot, and keeping the 500gb 5400rpm disk that came with the machine exactly where it is.
    I have read a lot about problems with different versions of the Vertex firmware and EFI revisions. Currently the Vertex has 1.30, and the MBP has 1.7 afaik. Should any of these be changed before I put the Vertex in?

    I will not be restoring the MBP from a backup, I'll just plain install it from CD. (External CD-drive, yes)
     
  2. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #2
    The Vertex is currently on 1.4/1.41: the 1.4 uses TRIM (only useful for Win7 people with a TRIM supported driver for the controller) and 1.41 uses Garbage Collection (GC; useful for 99% of the people). The 1.30 also uses GC but the 1.41 has a much better and faster GC algorithm so it is advisable to upgrade to that version.

    The problems with the EFI versions were not Vertex related but Apple related. A lot of people with new Mac with the EFI 1.7 version were experiencing strange problems regarding the hdd or ssd. It didn't matter if you were using a hdd or a ssd and it didn't matter which brand it was. Some people solved it by downgrading to EFI 1.6. Apple has pushed out an update (the performance update 1.0) for all of those people which solves the problems for like 99% of the people.

    Just make sure your OS X is up to date (run software update till there are no more updates) and the ssd runs 1.41 (not really necessary but just advisable) and you'll be fine :)
     
  3. tofagerl thread starter macrumors 6502a

    tofagerl

    Joined:
    May 16, 2006
    #3
    Fantastic!

    Thanks a lot, now I know exactly what to do :)
     
  4. tofagerl thread starter macrumors 6502a

    tofagerl

    Joined:
    May 16, 2006
    #4
    OK, I've got all the updates I can have, and the SSD is stalling at times. I tried copying a file from the internal HDD to the (internal as well) SSD, and it started out doing 80MB/Sec, and then went down to 5-10 with occasional stops at 0. At the moment it peaks at 33MB/sec, and then goes down to 5-10 very quickly.
    Nothing in the console, the EFI update and Performance Update can't be installed since I have 10.6.2.
     

Share This Page