Prevent wake on USB

Discussion in 'MacBook Pro' started by eldaria, Mar 5, 2009.

  1. eldaria macrumors member

    Joined:
    Jan 30, 2008
    Location:
    Sweden
    #1
    Hello.

    I would like to connect one of those Master/Slave Powersplitters to my Macbook Pro when I'm at home.

    However, this has given me an issue.
    When I choose Sleep, the Macbook goes to sleep, and a few seconds after the the splitter will turn off my screen, speakers, Printer and all other accesories.
    But as soon as this happens, The Mac wakes up again.
    For simplicity at home I have one USB connected to the mac, that goes to the built in USB hub of the screen.
    I tried to disconnect everything from the hub leaving only the hub connected.
    Now I have identified that as soon as the screen truns of and by that turns off the USB hub, the Mac will wake up.

    I have no need to have wake on USB, so I was wondering if there is a way to dissable this?
     
  2. hes macrumors newbie

    Joined:
    Aug 11, 2009
    #2
    Prevent Wake on USB

    I have exactly the same issue as Eldaria. I called apple and they did not have any recommendations. The tech support person was surprised there was no official answer from apple on this forum. Apple--could you please tell us how to turn off the feature whereby usb devices can awaken the mac?
     
  3. eldaria thread starter macrumors member

    Joined:
    Jan 30, 2008
    Location:
    Sweden
    #3
    I would be suprised if Apple would respond on this forum, since it is not affiliated with them.

    However the issue remains, I have gotten around the issue by using a different USB hub, (The other one is built into my screen.) And only connecting the printer when I need it.
    So it was actually two devices that would wake up the mac, the Printer and the built in USB hub in the screen.
    I also noticed that disconnecting devices while the computer is in standby, will also wake up the mac, so I suspect that this is what happends when the power goes off, it detects a device has been disconnected.
     

Share This Page