Prevent waking from sleep when receiving iMessages?

Discussion in 'MacBook Pro' started by kartcrg, Jan 5, 2017.

  1. kartcrg, Jan 5, 2017
    Last edited: Jan 5, 2017

    kartcrg macrumors member

    kartcrg

    Joined:
    Dec 7, 2016
    Location:
    Los Angeles
    #1
    I have my new MBP hooked up to an external usb c monitor which makes it act in the manner apple states here when receiving iMessages. Is there a way to prevent it waking from sleep when hooked up to my monitor and messages & calls are received?
     
  2. Mxbzz macrumors 6502

    Joined:
    Jul 22, 2012
    #2
    While not ideal, you could turn off the pop-up notification which should stop waking your Mac up. I still have my badge notification enabled and I *think* it stopped waking up my MBP.
    Turning off Power Nap did not do the trick in my experience.
     
  3. thesaint024 macrumors 6502a

    thesaint024

    Joined:
    Nov 14, 2016
    Location:
    Republic of California
    #3
    Same annoying issue for me too. I turned off most notifications except alerts and I turned off notifications at lock screen. I've only been casually paying attention since and it seems to have helped on the battery drain somewhat. There are so many options, it's hard for me to really understand what they are all doing.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    So...System Preferences>Notifications>Do Not Disturb>Turn On Do Not Disturb and checking When the display is sleeping doesn't prevent this?
     
  5. kartcrg thread starter macrumors member

    kartcrg

    Joined:
    Dec 7, 2016
    Location:
    Los Angeles
    #5
    You beat me to it. This works!
     

Share This Page