Preventing Hibernate on 2012 MacBooks

Discussion in 'MacBook Pro' started by scbond, Aug 12, 2013.

  1. scbond macrumors 6502

    Joined:
    Oct 16, 2010
    Location:
    Nottingham, UK
    #1
    Hey, does anyone have any decent knowledge dealing with pmset in Terminal in order to prevent hibernate kicking in after 4 hours, which affects the 2012 and on-wards MacBooks?

    I've tried turning standby, autopoweroff and acwake off and tried setting the delays to around 12 hours but it either doesn't seem to work or I encounter issues where I'll open my 2012 cMBP and I'll either find it is off (but still has the sleep light showing) or the white boot screen appears with the Apple logo and then the white loading bars (normally shown for wake from hibernate) which freezes on the last one.
     
  2. scbond thread starter macrumors 6502

    Joined:
    Oct 16, 2010
    Location:
    Nottingham, UK
    #2
    Anyone?

    When my Mac wakes up I get an annoying noise from the superdrive as it wakes...did some digging and found that the new hibernate rules are more than likely to blame.
     
  3. AeroZ macrumors 6502

    AeroZ

    Joined:
    Aug 7, 2013
    Location:
    Estonia
    #3
    Check this thread
    http://forums.macrumors.com/showthread.php?t=1505922
     
  4. alex0002 macrumors 6502

    Joined:
    Jun 19, 2013
    Location:
    New Zealand
    #4
    Perhaps this helps.
    http://forums.macrumors.com/showthread.php?t=1480259

    In terminal... set the sleep mode in shell:
    sudo pmset -a hibernatemode 0
    Remove the image:
    sudo rm /private/var/vm/sleepimage
    Create a blanked file:
    sudo touch /private/var/vm/sleepimage
    Make file immutable:
    sudo chflags uchg /private/var/vm/sleepimage
     
  5. scbond thread starter macrumors 6502

    Joined:
    Oct 16, 2010
    Location:
    Nottingham, UK
    #5
    That has nothing to do with the superdrive making a noise. It's doing so because the MacBook is going into hibernate mode and then waking from it. Something which was implemented by Apple late spring/early summer.



    I have tried disabling as mentioned but have noticed the setting I make either come back after a day or so or are completely ignored so I will try deleting and replacing the sleep image file as you have suggested alex, thanks.

    Is it perfectly safe to do? I'd probably keep a copy of the original somewhere safe.
     
  6. AeroZ macrumors 6502

    AeroZ

    Joined:
    Aug 7, 2013
    Location:
    Estonia
    #6
    Everything you need to do is mentioned in the thread that I posted. So "yes, you're welcome"
     
  7. scbond thread starter macrumors 6502

    Joined:
    Oct 16, 2010
    Location:
    Nottingham, UK
    #7
    Again, that isn't the issue I'm having. The issue I have is stopping the hibernate mode which was forcefully set by Apple on the 2012 MBP. While that thread gives directions to change hibernate through Terminal and delete the sleep image in the case of an SSD, I still get the settings overridden by OS X.
     
  8. liya1201 macrumors member

    Joined:
    Sep 8, 2010
    #8
    I am having similar issue. The screen of my 2012 cMBP got mess up after it woke up from deep sleep (hibernate) that always associated with a noise from the superdrive. I recently adjusted the "Computer sleep" to "Never" in the Energy Saver in System Preferences, which seemed to have prevented my cMBP from deep sleep.
     
  9. chriscl macrumors 6502

    chriscl

    Joined:
    Jan 4, 2008
    Location:
    Stuttgart, Germany
    #9
    For what it's worth - on my mid-2012 cMBP, I have found (accidentally) that having a USB drive plugged in, in my case, my Time-Machine backup drive, stops my MacBook Pro going into "Full" hibernate mode.

    When I close the lid at night, it goes to sleep, and when I open the lid the following day, I'm back at the login prompt within a second or two.

    Remove the USB drive, and hibernate kicks in after four hours, cue lengthy wait and the inevitable spinning-up of the DVD drive when it comes back to life.

    I'd hesitate to call this a "fix", as it no way is, but it's curious that having an external USB drive plugged in seems to prevent the MBP from fully hibernating.
     
  10. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #10
    Inaddition to Alex2000's post
    "In terminal... set the sleep mode in shell:
    sudo pmset -a hibernatemode 0
    Remove the image:
    sudo rm /private/var/vm/sleepimage
    Create a blanked file:
    sudo touch /private/var/vm/sleepimage
    Make file immutable:
    sudo chflags uchg /private/var/vm/sleepimage"

    If pmset -g shows: autopoweroff**1,
    disable this automatic hibernation mode (happens even if hibernation mode is set to 0 on the new Mac mini 2012 and iMac, and MBP 2012?)
    sudo pmset -a autopoweroff 0
    Set the safe sleep timer (standbydelay) to 20 hours, default is 4200
    sudo pmset -a standbydelay 72000
    5. sudo pmset -a standby 0
    ... bit 3 of hibernatemode encourages the dynamic pager to page out inactive pages prior to hibernation. So this appears to be why swap can used after sleeping (even though hibernatemode is 0, so bit 3 is off). Disable this new, possibly buggy behavior by switching off standby:
    sudo pmset -a standby 0
    This may help you out.
     
  11. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #11
    If preventing sleep/hibernate/screensaver is ok, the free "caffiene" app works. I've accidentally left caffiene active, and my mid-2012 rMBP has stayed on for hours and hours (giving me temporary screen burn-in :eek:).

    (Yes, it really does prevent screensavers/screen dimmers from activating.)
     

Share This Page