Preview Application Broken - No Folder Icons

Discussion in 'macOS' started by redonion, Aug 27, 2010.

  1. redonion macrumors newbie

    Joined:
    Aug 27, 2010
    #1
    So, I'm working away today on my iMac OS X 10.6.4 mainly just screwing off visiting social networking sites on the web. Later, I minimize my windows, and notice the icons on my desktop are a little strange. Upon further research, all the folder icons are gone (or they are transparent). You can see the folder name, but no icon associated with the folder. Also, all my pdf, jpg, png, etc are now associated with Adobe (either Acrobat or Photoshop CS). They used to be associated with the Application "Preview".

    I've rebooted and tried a lot of other things to restore icons, and nothing has worked. Here is what I have found. I dont think it's an icon problem, I think it's a "Preview" problem.

    If I click on the "Preview" icon nothing happens. If I right click on a jpg (for instance), and select "Open With" - Preview is not there.

    If I Choose "Open With Other..." within the Application folder, "Preview" is grayed out.

    If I select "Enable All Applications" then "Preview" is no longer grayed out. But when I select it, and select "Open", nothing happens.

    Everything "appears" to be working normally. Just I no longer have any folder icons on the desktop or within finder. And I am no longer able to open anything within "Preview" All my files are now associated with another application (which works fine) but not with preview.

    I finally found a way to copy a folder icon to the "invisible folder". If, for example, I right click on my "DropBox" folder (which I can see) and select Get Info, I can copy that icon to a "Normal/Default" folder such as Documents.

    So I did that to about a dozen folder and it worked. But there is no way I'm going to do that to 1000 folders!

    Today, Aug 27, I get a security update and a few other things from Apple and I install them. Then I'm asked to reboot. After I install the updates, and reboot my iMac, even the folder I cut n pasted are now gone. And so are the jpg gif and pdf icons are now gone too. Prior to the update, the pdf, jpg and gif files had a Photoshop CS icon (instead of the previous "Preview" icon and preview that I'm trying to restore.). Now even the Photoshop and Adobe icons are gone.

    This is getting crazy! Any help? Anyone?



    Wish I could attach an image here then you could see exactly what I'm talking about. I've spend a couple hours now trying to figure it out. Still no solution.

    Help? Anyone?

    Funny thing, I just uploaded screen shot of my problem. But, when I use the Manage Attachements Window here to select the file I want to upload, I can see ALL THE CORRECT Icons PERFECTLY! hahaha

    But, when viewing on my desktop on within Finder, the icons are gone. I'll try to do another screen shot and you'll see.
     

    Attached Files:

  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    "I've tried alot of other things" is not a useful summary. You should state what you've tried. Why should anyone waste time suggesting something only to have you post back with, "Yeah, I tried that and it didn't work."
     
  3. redonion thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #3
    I've tried rebooting. I've tried, changing the screen resolution, I've tried logging in as a different user, I've restarted Finder using the command line killall Finder), I've tried "View > Clean up", I've deleted com.apple.finder.plist and com.apple.FolderActions.plist then restarted, and I've reset my NVRAM by rebooting while holding down Command-Option-P-R. So far nothing has worked.

    Any more suggestions or idea?
     
  4. ThirteenXIII macrumors 6502a

    Joined:
    Mar 8, 2008
    #4
    Safe Boot to an admin account and repair permissions, restart and see if it still occurs.

    What happens when you right click and get info on a folder?

    does an icon show up there?


    /

    thinking you must have edited some of the System icons? changed some folder icons at some point?
    If you customized any of the UI you can get into problems easily i find, best bet is to restore to the original icons and probably best not to touch them.
    Ive seen many issues with people customizing that accidentally change one thing that caused a chain reaction.
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    Are you able to launch Preview at all? Is it still in your Applications folder? If it is, you might try deleting:
    /Users/username/Library/Preferences/com.apple.Preview.plist​
    If that doesn't help, you can install Pacifist to reinstall Preview from your Mac OS X install disk.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    There's a plist file for that too.

    com.apple.systemuiserver.plist
     
  7. redonion thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #7
    No, I cannot launch Preview at all, and yes, it is still in my applications folder.

    I tried deleting ~/Library/Preferences/com.apple.Preview.plist, then I rebooted. That did not help.

    I'm downloading Pacifist right now. I'll have to find Preview on my Mac OS X disk and try reinstalling it. I'll try that tonight sometime.

    I deleted com.apple.systemuiserver.plist then rebooted. Still the problem exists.

    I rebooted in Safe Mode as admin then ran repair permissions. It found about a dozen files that said something about set to 0 should be 80 and visa versa. After rebooting again, the problem still remains.

    I've never edited any icons. I've always kept the default icons. Dont even know how to edit icons. Never customized the UI except a background image.

    As I side note, I also created another Admin account. Logged in as the new admin and still have the same issue.

    I'll try to reinstall Preview tonight or tomorrow morning. Sure hope that helps :) This sucks!
     
  8. grexi macrumors newbie

    Joined:
    Sep 10, 2010
    #8
    You're not alone

    You're not the only one with this issue. Although the file preview works fine for all images, Preview won't open .png or .jpg or .pdf... Only I have the same problem with other Mac applications, namely TextEdit (cannot open .rtf) and QuickTime X (cannot open .avi)!

    I verified my disk in Disk Utility, and there seems to be no problem there. I'm starting to feel that my only hope is backing up my system and re-installing Snow Leopard.

    Any help welcome.
     
  9. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #9
    Rebuild the LaunchServices database
     

Share This Page