Preview bug with PDFs and text

Discussion in 'OS X El Capitan (10.11)' started by Poncho, Oct 24, 2016.

  1. Poncho macrumors 6502

    Poncho

    Joined:
    Jun 15, 2007
    Location:
    Holland
    #1
    I just upgraded to El Capitan from Mavericks. (Yes, I know, I like to wait a while to ensure all bugs are ironed out...) But I I have a bug which is driving me mad. I used to be able to extract text from a PDF using the paid for app To Text Converter, but when I used this certain letters (i,f and l) are missing rom exported text. So I downloaded and paid for Filejuicer. Same thing. Now I have spent quite a bit of money. Grrrr.

    So I make my own Application using Automator (wish I had done this in the first place as it only took two minutes and cost me nothing) and still the same problem.

    So highlighted some text in a PDF and copied and pasted it into a Text document and still the same issue.

    So I guess it's a problem with Preview, PDFs and El Capitan.

    Anyone know of a fix (please don't say upgrade to Sierra as my Mac is so old now it won't support it.)

    Thanks to all who may reply...
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    Are you sure that this particular PDF worked in Mavericks? Not all PDFs work with Preview, some may have non-standard (wrong) syntax. If it is a scanned document, it may also be a flawed character recognition.

    You should download Adobe Acrobat for full compatibility, it usually manages to work with more documents, however flawed.
     

Share This Page