Preview died on me "This application cannot work with this version of OS X"

Discussion in 'macOS' started by jbunit009, Aug 27, 2008.

  1. jbunit009 macrumors newbie

    Joined:
    Aug 27, 2008
    #1
    Basically, one day I tried to open preview and I got the above error "This application cannot work with this version of OS X".

    I didn't make any changes to my system, I didn't install any new programs, I didn't update OS X. I'm really at a loss for what caused this and it is annoying me greatly.

    Any ideas? Google turns up nothing and I haven't had any luck searching the forums.
     
  2. iwuzbord macrumors 6502

    iwuzbord

    Joined:
    Jul 31, 2008
    Location:
    New York City
    #2
    did you happen to move the preview app, or rename it.
    if not, reinstall it using the first restore disk that came with your mac
     
  3. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #3
    Not sure what might have caused it, but you might try restoring preview from Time Machine if you are on Leopard and using TM.

    If not, I'd recommend reinstalling OS X in order to make sure that whatever it is didn't corrupt anything else. Consider doing a hardware test, if your HD is failing, that may have caused the corruption.
     

Share This Page