Preview MIA

Discussion in 'Mac Basics and Help' started by umijin, Jan 15, 2007.

  1. umijin macrumors newbie

    Jan 10, 2006
    For unknown reasons, my Preview app has stopped responding. I can double click on it or one of its supported file types, and the app icon bounces, but never opens.

    An old support article on MacWorld suggested I delete it's preferences from the Libary/applications file. I did this, with no result. I've also re-booted the machine, as well as repair the permissions with disk utility.

    What's up with this? I haven't noticed other apps wigging out like this, but wonder if it is related to a repair I did with DiskWarrior recently.

    Oh, and this is with OS 10.4.8 on a 12" G4 PB.

    Thanks in advance.
  2. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    Have a look at this thread. Reinstalling the app will hopefully solve the problem if deleting the preference files didn't help.
  3. umijin thread starter macrumors newbie

    Jan 10, 2006
    Nope - it didn't work. I did it two ways. First, I tried copying the preview app from my G5. Next I used Pacificist and grabbed Preview from an install disk and installed it. In both cases, no change at all in behavior. The app just doesn't open. Grrr.....
  4. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    And you got rid of both Preview preference files before trying those steps so that they'd be recreated with the new apps?

    I don't know...I'm stumped if that doesn't work.
  5. umijin thread starter macrumors newbie

    Jan 10, 2006
    Yes I did, unless they are hiding in some other folder. I deleted prefs from both the user library and the system wide library. Clicking on preview didn't regenerate the prefs.

    I'm not a newbie, and usually have fixed issues like this on my own. This one really irritates me.
  6. tyr2 macrumors 6502a


    May 6, 2006
    Leeds, UK
    Have a look in the system logs. Use 'console' in the utilities folder. See if it logs anything when you try to start the app.
  7. umijin thread starter macrumors newbie

    Jan 10, 2006
    Ahh... console... OK here is the log when it happened. Looks ugly.
    dyld: Library not loaded: /System/Library/PrivateFrameworks/Slideshow.framework/Versions/A/Slideshow
    Referenced from: /Applications/
    Reason: image not found
    Jan 18 17:38:26 Curtsan-PowerBook crashdump[519]: Preview crashed
    Jan 18 17:38:26 Curtsan-PowerBook crashdump[519]: crash report written to: /Users/Curtsan/Library/Logs/CrashReporter/Preview.crash.log
  8. mercurial0ne macrumors newbie

    Aug 27, 2007
    Try this.

    Hey Umijin,

    I had the exact same problem on the exact same machine.
    Mac G4 PB 12"
    dyld not loaded yada yada..

    Heres how I solved it.

    After the disk utility, repairing permissions, and then doing the same again with Onyx it still didn't work. :confused: I then went to the apple website under downloads and got the "SecUpd2007-007Ti.dmg". I then rebooted into safe mode
    To do this reboot and as soon as you hear the 80's mac sound press and hold the shift key until you see both the apple and the turning gear, then let go. Its gonna take FOREVER :mad: cause it does a directory check of the hard drive like the Repair Disk and some other good stuff. ;)
    Ok. Two hours later you'll see your login screen. I usually go straight into the only account but in safe mode it goes to the login screen anyway.. so select your account, type password and your in.
    Now once I was in safe mode I mounted the .dmg image from the apple site and ran the .pkg inside. When it finished I pressed the restart button that it offered but it did not reboot so i did it manually from the console. "reboot now"
    After that no more problems for me.

    I hope maybe the same works for you.
    Good luck.

Share This Page