Preview not opening multiple JPG images

killmoms

macrumors 68040
Original poster
Jun 23, 2003
3,722
13
Washington, DC
Okay, weird-ass problem: Preview randomly doesn't behave correctly anymore. PDFs open fine, but when I try to use Preview to open a series of JPG images (or even a single JPG image) Preview doesn't respond. If I click on the desktop to switch to Finder and then click on Preview again, the first image in the series opens, but Preview's controls are non-responsive (drawer doesn't open, can't page up or page down, can't zoom in/zoom out, can't scroll, etc.). I've tried deleting the plist but that didn't help, and rebooting had no effect either. I might also add that I haven't done anything to my system between when this worked (this morning) and later today when it suddenly didn't work. Any ideas?

EDIT: Not sure it's important, but I'm running OS X 10.3.8, and have been since it came out—Preview's troubles started just today, well after the upgrade. So there's that, for what it's worth.
 

LimitedEdition

macrumors member
Jan 14, 2005
60
0
Is it possible that it's one particular jpeg that's causing it to crash? Maybe try with some completely different files...
 

killmoms

macrumors 68040
Original poster
Jun 23, 2003
3,722
13
Washington, DC
Nevermind, that gave me an idea... I tested it with some JPGs in a different folder and it worked. That reminded me this morning that I'd changed the folder name of my Yotsubato! mangas to ?????to try and help me remember some hiragana, and changing the folder name back to English fixed the problem.

But if Preview balks on folders named with Unicode characters... that's a pretty serious bug.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.