Preview refuses to open PDF's on macOS 10.12.3 update

Discussion in 'macOS Sierra (10.12)' started by FocusAndEarnIt, Jan 27, 2017.

  1. FocusAndEarnIt, Jan 27, 2017
    Last edited: Jan 27, 2017

    FocusAndEarnIt macrumors 601

    FocusAndEarnIt

    Joined:
    May 29, 2005
    #1
    Need some help. Updated to 10.12.3 this morning, and can't open PDF's in preview, which is a big issue for me as I handle a lot of PDF's. They want to all open in Photoshop CC. I uninstalled Photoshop CC, now they open in Safari. ??? I go to open manually in Preview, and it just doesn't do anything with the command, like I didn't even ask it to. Doesn't hang or anything, just doesn't open it and gives no error. I tried deleting com.apple.preview.plist and that didn't work. I created a new user account to see if I could open them in there, and Preview will open PDF's there! I would really like to not have to migrate to a new user account if it can be avoided.

    BTW - I can open jpeg's in Preview without issue.
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    Do a Get Info on a PDF. Change to Open with Preview. Then select Change All.
     
  3. FocusAndEarnIt thread starter macrumors 601

    FocusAndEarnIt

    Joined:
    May 29, 2005
    #3
    I've done that, and I've also tried manually opening the files and it doesn't do it. Thanks though.
     
  4. Signum17 macrumors newbie

    Joined:
    Jun 11, 2013
    #4
    Try this
    Try this:

    Open your user/Library folder by holding down the Option key and selecting "Library" from the Go menu in Finder.

    Open the Containers folder and delete the com.apple.preview folder.
     
  5. FocusAndEarnIt thread starter macrumors 601

    FocusAndEarnIt

    Joined:
    May 29, 2005
    #5
    I tried that too, no luck. Thank you for responding!

    Fixed It!! I downloaded Onyx, and went to Maintenance -> Rebuilding tab, executed the task and everything went back to normal. :)
     

Share This Page