Preview Search

Discussion in 'Mac Basics and Help' started by glenncal, Jun 7, 2009.

  1. glenncal macrumors member

    Joined:
    Jun 7, 2009
    #1
    Does any one know exactly how searching in Preview works? Here, searching for one word works perfectly, but then as soon as I continue entering the second word Preview seems to search for instances of those words separated from each other.
    I tried using quotation marks around my term but then nothing is found (Preview tries to search for actual quotation marks in the document instead).

    Is this how it usually works or is something wrong on my end? And if not, how would you usually search for two consecutive words in a PDF document with Preview?

    Thanks

    Edit: I'm using OS X 10.5.7
     
  2. techound1 macrumors 68000

    techound1

    Joined:
    Mar 3, 2006
    #2
    Does using a + symbol work? If you're searching for "Mac Pro", does "Mac +Pro" or "Mac + Pro" work?
     
  3. glenncal thread starter macrumors member

    Joined:
    Jun 7, 2009
    #3
    No, it doesn't seem to work with a + either. Opening the PDF in Safari, and searching there will give me the expected result (ie. searching 'Mac Pro' gives me all instances of 'Mac Pro'). The same search in Preview gives me all instances of 'Mac' and all instances of 'Pro' ..
     
  4. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #4
    Search using single quotes around the phrase, ie. 'Mac Pro' and it will find only instances of Mac Pro.
     
  5. glenncal thread starter macrumors member

    Joined:
    Jun 7, 2009
    #5
    Thanks! I found out that it works with double quotes too, but in both cases you need to complete the search term before it finds anything (hence, why I thought it wasn't working). It's a bit weird that it doesn't find whole phrases without any quotes (as in Safari), but at least it works this way.
    Thanks
     
  6. Goride macrumors newbie

    Joined:
    Jun 15, 2010
    #6
    I need help with a similar issue.

    Preview will not allow me to search for number with a decimal in it. For example, I cannot search "MR 1.5" to find MR 1.5 in the document. It will return zero results. (even though there are plenty of them throughout the document)

    However, I CAN search for "MR 1" and it WILL return all results with MR 1 in it. I can even search for "MR 1." and get results with MR 1. (with the . attached to the phrase)

    But, this isn't acceptable because this is a huge pdf with MR 1.1, MR 1.2, ..., MR 1.19, etc.

    Is there a way I can get it to return values with a decimal in it? EX: MR 1.5 or MR 1.11

    (also I should note that this pdf isn't a scanned document, and all text is perfectly selectable, copy and pasteable, etc.)
     
  7. dbkats macrumors newbie

    Joined:
    Oct 22, 2011
    #7
    I have the same issue. Don't know how to fix.
     
  8. JKColo22 macrumors regular

    Joined:
    Feb 19, 2009
    #8
    I realize this is an old post, but I just stumbled across this. Thought I would post to keep it relevant in Google's search results.

    Preview's VERY weird searching has driven me nuts for years. I thought the same thing as Glencal (search doesn't populate until you finish the quote, so I didn't think it worked). Nice work guys!
     

Share This Page