Preview won't open any PDF files, just crashes

Discussion in 'OS X Mountain Lion (10.8)' started by martinweiss, Aug 1, 2012.

  1. martinweiss, Aug 1, 2012
    Last edited: Aug 1, 2012

    martinweiss macrumors newbie

    Joined:
    Aug 1, 2012
    #1
    I've tried opening a lot of PDF files, but Preview just crashes. Extremely annoying.

    Would the problem report be of use to anyone? It says Exception Type: EXC_CRASH
     
  2. martinweiss, Aug 1, 2012
    Last edited: Aug 1, 2012

    martinweiss thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #2
    I was looking in the wrong part of the forum. Apparently I've experienced what some people experienced with Lion: http://forums.macrumors.com/showthread.php?t=1192604

    I went to Disk Utility, repaired permissions. There was something to repair, but it didn't fix the problem. I can quick look PDFs, but not open them. Hmm.

    I also tried to delete the contents of ~/Library/Containers/com.apple.Preview/, this also doesn't help.

    Suggestions anyone?
     
  3. martinweiss thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #3
    No ideas? This is really really annoying, I'm not sure what to do.
     
  4. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #4
    Did you trash any Preview .plist files?
    Check the system log?
     
  5. martinweiss, Aug 2, 2012
    Last edited: Aug 2, 2012

    martinweiss thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #5
    I've deleted the files in ~/Library/Containers/com.apple.Preview

    Are there other files I can delete?

    This is what I get:

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_CRASH (Code Signature Invalid)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
     
  6. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #6
    Search in Preferences, ~/Library/Preferences/ for any Preview .plist files.
     
  7. martinweiss thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #7
    There weren't any. I'm going to have to reinstall ML today, I must have transferred some files I shouldn't have, maybe I accidentally copied over the Keychains folder? Could be it since it's complaining about code signing. Weird though, I've never had any problems like this before.
     
  8. martinweiss thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #8
    Alright. I have reinstalled Mountain Lion twice now. I even downloaded it from App Store again. This has proved to be one big PITA. I need help, I'm not sure I know how to solve this on my own. I am currently writing my Master's thesis. Apple, I am extremely disappointed in you. Preview is such a fundamental application, now I'll have to install 3rd party software:mad:
     
  9. martinweiss thread starter macrumors newbie

    Joined:
    Aug 1, 2012
    #9
    Okay, I finally got it working, but I'm not sure what the problem was...

    I found someone saying that using Pacifist one should be able to extract separate files from an OS X installation disk. Using Pacifist I was able to extract Preview.app, copy it to my Desktop. I tried opening it from the Desktop and opening a file, it worked!

    Now, since it's not possible (I couldn't find a way) to delete Preview in the Applications folder I right-clicked to Get Package Contents. I did this for Preview on my Desktop (from the installation USB disk) and copied all the contents from Preview (Desktop) to Preview (Applications).

    Apparently this solved my problem. I have searched to see if anyone else had the problem, but I could only find problems with Preview under Lion. Maybe Preview is corrupt in my ML installation? Strange, because I tried to download it again.

    I have to admit I am really quite surprised to see something like this happen, and to be honest my initial ML-happiness is somewhat reduced now...
     

Share This Page