Prey: UB but only works in Rosetta?

Discussion in 'Mac and PC Games' started by siorai, Feb 11, 2008.

  1. siorai macrumors 6502

    Joined:
    Sep 14, 2007
    #1
    I have been having a hell of a time getting Prey to run. The most annoying part is that the very first time I installed it, it ran perfectly right after the installation. The next day though? No go. The icon would bounce a couple times in the dock and then disappear. Subsequent installs have not worked at all. I've even tried installing as my main user with admin rights and as another user with just standard rights. Nothing is working. Until last night. I checked the info for the icon and noticed a check box for Rosetta. I checked that and the game started up. Of course it ran horribly, but it still ran.

    So here's the big question. Why wouldn't it run normally? It's a Universal Binary. I'm running it on an early '08 Mac Pro (vanilla config in sig) with Leopard.
     
  2. siorai thread starter macrumors 6502

    Joined:
    Sep 14, 2007
    #2
    64 views and not one suggestion? :(

    I guess I could always resort to playing it in Windows again, but I'd really rather not.
     
  3. bmb012 macrumors 6502

    Joined:
    Jul 25, 2006
    #3
    Well, if it ran correctly only on the first time, you could try trashing the settings for the game and launching again...
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  5. redsteven macrumors 6502a

    redsteven

    Joined:
    Aug 22, 2006
    #5
    yeah... repair permissions, and delete the preferences and any other associated files you can find.

    Also, try contacting the developer
     
  6. colocolo macrumors 6502

    Joined:
    Jan 17, 2002
    Location:
    Santiago, Chile
    #6
    I had the exact same problem with C&C. Repair permissions didn't work (although it turned out to be a permissions issue).
    Here's what I did:
    - open the console, and see what it says right after it closes unexpectedly.
    - there are probably a couple of files in there which it doesn't have permission to write to (I also encountered the issue where it said it had too much permissions so I had to restrict them - go figure).
    - open the Terminal, navigate to the specified files, and fix them. That did the trick.

    In my case, the files where hidden inside the Cider part, so that's why I'm assuming you will have a similar problem.
     

Share This Page