Print Priority Mail Label on a MAC in Word 2016

Discussion in 'Mac Basics and Help' started by gogreen1, Mar 5, 2018.

  1. gogreen1 macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #1
    I'm trying to print a priority mail label (4.25x5.5) on my iMac with MS Word 2016 for Mac on a Brother MFC-L2740DW printer. Trouble is, this doesn't work as it did for me in Windows. When I feed the label through the paper tray, back cover open, the label prints as if it were an 8.5x11 page. In Windows, I'd feed the label through, centered in the manual feed slot paper guides, and it would print just fine. In Mac, I have to align the label as best I can against the left paper guide.

    The printer user manual says that the Brother printer driver window will appear after using Word's printer command, but that doesn't happen in Mac.

    What am I doing wrong? Thanks.
     
  2. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #2
    Hey -

    A couple things to check:

    1. Find your paper size, or make a custom paper size in Page Setup...
    2. Use the pull down menu from the top toolbar instead of the keyboard shortcut. Some apps on Macs auto print—bypassing the print dialog box—if you use Command+P, and some do the same if you use the print button. I just tried Word 2016 and I got a print dialog box (though not with a Brother printer)....but be aware some software chooses to bypass it.
     
  3. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #3
    Thanks, hobowankenobi. I've been following these instructions. Attached is, I hope, a better illustration of the problem. I initially fed the label through the manual feed slot. In my printer, the feed slot paper guides center the paper. But when I print, the label text appears off to the left (arrows). When I put the same label through the printer again, this time placing the label flush left in the feed slot, it prints correctly. It's as if I need to tell Word that I'm using the feed slot, not the regular paper tray. How do I do that in Word 2016? Thanks again.

    label printing.jpg
     
  4. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #4
    You do that via the Paper Feed option in the print dialog box...and select the bypass tray (Brother may call it something else...like: manual feed tray). But the odd thing is, typically it won't print at all if the tray is NOT selected. Seems like it is automatically pulling from the bypass tray...which is usually good.

    This is a head scratcher. Stuff you have probably already verified:

    Paper size
    Paper feed
    Paper orientation (landscape vs portrait)
    Paper margins (the defaults are typically .25 top, left and right, and .56 bottom; you can change those down to about .12 or so...varies a bit by printer)

    The only other thing that comes to mind...which gets complicated with margins...is the size of the print. Most printers have a couple options, like:

    Actual size
    Fit
    [Manual size selection via a percentage]

    Try using Fit to Size or its equivalent, if the default is actual size (or 100%) so that no text wraps or gets chopped off. Easier (when exact size is not critical) than futzing with margins and layout.
     
  5. gogreen1, Mar 6, 2018
    Last edited: Mar 6, 2018

    gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #5
    The label is automatically pulling from the manual feed tray, but it still prints as before.

    I do not see a paper feed option in the print dialog box. There is no place where I can select the bypass tray or the manual feed slot.

    I have verified the paper size, orientation, margins.

    I wonder if this has something to do with the Mac printer driver. I see no options to change the paper feed.

    As an update, I found the tray settings: Print > Copies & Pages > Media & Quality. I tried both Tray 1 and manual feed, but neither worked. Where would I find the percentage item you mentioned? Thanks.
     
  6. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #6
    I FIXED IT!! For others having this problem, I uninstalled and reinstalled the printer and driver. I think the print driver is different from the original Brother drivers I had installed. I think the driver said "CUPS"? I also checked "scale to fit paper size." Works fine now. Thank you, hobowankenobi, for your help with this problem!
     
  7. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #7
    Good deal. Probably just a bug or driver issue, and the update resolved it.

    FYI: CUPS is the underlying printing system on Macs (and pretty much all Unix and Linux systems.) Windows has its own, different printing system....which is a big chunk of the difference between printing on each platform. Lots of differences, but probably the biggest is Postscript vs. PCL.

    CUPS was an open source thing forever, but Apple has taken it over....likely so they are not dependent on any other group of developers that might go a different direction then what Apple wants. Still open source, and used by other platforms, but Apple can now certainly tightly integrate and plan for chances.

    Apple will update the version of CUPS pretty much with each major OS release (like from 10.12 to 10.13), and sometimes printer drivers must be updated to function correctly, to match the version of CUPS. So...never update to a full OS if you have an older printer...until you are sure that the printer is supported (new or tested and working drivers) for the new OS.

    Brother has always been good about Mac support, and updating drivers on older machines, so hopefully you will see no issues. Some other brands....no guarantees.
     
  8. gogreen1 thread starter macrumors regular

    gogreen1

    Joined:
    Nov 20, 2017
    #8
    Good to know. Thank you. I'm running version 2.2.5.
     

Share This Page

7 March 5, 2018