"Print Test Page" finally works, but stuck on A4 paper?

Discussion in 'macOS' started by Makosuke, Mar 24, 2008.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    One of the things that has always bugged me about OSX's printing subsystem was the lack of a test page feature. It does appear in the menus under 10.4, but at least on my setup it's always grayed out for our networked printers.

    I happened to look at it under 10.5.2, and realized that for once it wasn't. Yay! I fired off a test page, and indeed one popped out. It appears to be generated by the CUPS system, based on its text.

    Then I tried our other printer, and it didn't print, because it had been sent as A4 paper rather than US letter, and that particular printer will hold the job if the appropriate paper isn't available rather than forcing it. I looked at the print that did work, and it also appears to be A4, since the bottom 2cm is cut off (based on the rulers on the page), it's just that that printer wasn't picky about it.

    The system is set to US-standard for everything--location, timezone, language, printer default paper size--so not sure where this would be set, or if it can even be changed.

    Anyone know? Also, is there some trick to enabling those test pages under Tiger?
     
  2. bradley8424 macrumors newbie

    Joined:
    Aug 6, 2008
    #2
    I am having the exact same issue. I guess it's not really a big deal since each program has to tell the printer what paper size to use and there really isn't a system-wide default. However, it would be nice to be able to print a test page without the printer alarming.
     
  3. jdavtz macrumors 6502a

    Joined:
    Aug 22, 2005
    Location:
    Kenya
    #3
    Here I have a UK iMac set to UK/British everything and the test prints are ALWAYS letter-sized. I've always wondered how to change it to A4, which is what we always use in the UK!

    I wonder if changing something to USA settings flips it to Letter size? Try yours set to British English. I can't believe that should be the solution really though. Especially as it's backwards.
     

Share This Page