Printer + Airport Extreme Help

Discussion in 'Mac Basics and Help' started by eric/, Oct 27, 2011.

  1. eric/ Guest

    eric/

    Joined:
    Sep 19, 2011
    Location:
    Ohio, United States
    #1
    Hello,

    I recently gave my parents an Airport Extreme and I'm having trouble getting their Windows Vista machine to recognize the printer. Here is the setup:

    1 Windows Vista Desktop computer
    1 Macbook Air
    1 Macbook Intel
    1 Canon MP 210 printer

    The Airport is plugged in normally, the printer is plugged into the Airport via USB, and the Vista computer is plugged into the Airport via Ethernet as well. Both of the MacBooks connect wireless.

    ------------

    Both the Macbook books recognize and print to the printer, but the Vista machine does not. I tried setting up the printer through the Vista "add a wireless printer" steps but it doesn't find the printer on the network. Obviously it works, and this is probably something really easy, but I haven't set up a printer on a Vista machine in this fashion before.

    Any help would be appreciated.
     
  2. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #2
    I'm not positive this will work for you, but I believe that you need Bonjour for Windows:

    http://support.apple.com/kb/dl999

    I've successfully used that to find (mostly automatically) and configure Mac-served printers on Windows in the past, though I haven't needed it in a while.
     
  3. matspekkie macrumors member

    Joined:
    Oct 19, 2010
    #3
    bonjour

    Agreed you need bonjour maybe the easiest thing to do is install the cd that came with your airport extreme on the windows computer once you done that it will work.

     
  4. eric/ thread starter Guest

    eric/

    Joined:
    Sep 19, 2011
    Location:
    Ohio, United States
    #4
    Well, that got the printer recognized. Now I'm just having trouble getting it to actually print what I send it. It either just doesn't do it, or it takes a very long time. Hmm.

    Thanks for your help with that though. That was pretty much what I needed.

    ----------

    Actually, everything works fine now. Only issue is I get a "printer is not responding" error and then it prints.

    No clue, as long as it works idc.

    Thanks a lot guys for your help.
     

Share This Page