Printer all of the sudden needs software?

Discussion in 'MacBook Pro' started by ProseOne, Aug 8, 2011.

  1. ProseOne, Aug 8, 2011
    Last edited: Aug 8, 2011

    ProseOne macrumors newbie

    Joined:
    Aug 8, 2011
    #1
    I am running Lion on a 2011 MBP and 10.6.8 on a 2009 MB unibody and printing wireless with a Brother HL-2170w. I have had no trouble using this printer until today, when randomly both macbooks say there is software missing and I need to install it via apple. I hit the "find software" prompt and after a minute or so it says "operation could not be completed, no more information on this problem available". I downloaded the Brohter printer driver set from apple.com, but had no luck with those. I am getting frustrated at this point as I cannot find any info on the web about similar problems. Any ideas? I have not yet tried to print through usb.

    [​IMG]
     
  2. theheadguy, Aug 11, 2011
    Last edited: Aug 11, 2011

    theheadguy macrumors 65816

    Joined:
    Apr 26, 2005
    Location:
    california
    #2
    This isn't just a MBP problem, this is a general OS X 10.6.8 printing issue. There are over 23 pages of people who have had the same/similar issues here: https://discussions.apple.com/thread/3137602?start=0&tstart=0.

    The fix listed does not work for me, and I also have the 2170W and was printing wirelessly. I called Apple tech support - they were zero help.

    UPDATE: A comment in the following article fixed it for me! Just remove the printer (from System Preferences) and add it again. Voila! http://reviews.cnet.com/8618-13727_7-20074154.html?assetTypeId=12&messageId=10938837
     
  3. GuitarG20 macrumors 65816

    GuitarG20

    Joined:
    Jun 3, 2011
    #3
    Yeah... I got a new printer for college, and I had to find drivers for it... The computer didn't have it included in all the others, neither did the Samsung US website... I had to download them off the UK site. :cool: :p

    I think there's always problems with printing off OSX :confused:
     

Share This Page