Printer Dell B1160W - Mavericks

Discussion in 'Mac Accessories' started by lostregr, Oct 16, 2013.

  1. lostregr macrumors newbie

    Joined:
    Mar 18, 2013
    #1
    I have tried everything in order to install any drive from Dells site. everything fails while the installer starts and it doesnt move

    [​IMG]

    I have tried different versions but nothing seems to work. What can i do? Any ideas to get the drivers manual to my Library?:mad::mad::mad::mad:
     
  2. oldhifi macrumors 6502a

    oldhifi

    Joined:
    Jan 12, 2013
    Location:
    USA
    #2

    try downloading to CD/DVD first then load off of that..
     
  3. SteelBlueTJ macrumors 6502

    Joined:
    Apr 2, 2012
    Location:
    USA
    #3
    I have the same printer and I am experiencing the same issue. I tried both downloading it from the site and from the CD. Always get stuck on the same screen as shown by the OP. Anyone have any luck with this yet?
     
  4. MOOSHINE macrumors newbie

    Joined:
    Oct 28, 2013
    #4
    Used a different driver and was able to print!

    I also have the B1160W and have the same issue.
    I ended up... turning on the printer, connect with USB, go to System Preferences/Printers & Scanners/ and clicked on the + to add a printer.
    Select the Dell B1160W Mono Laser Printer on the list.
    Click on Choose a Driver.
    I picked the Samsung ML-2525W Series.
    Worked for the one page I printed.
    Hope it works for you guys.
     
  5. SteelBlueTJ macrumors 6502

    Joined:
    Apr 2, 2012
    Location:
    USA
    #5
    I tried that but I don't have the samsung on my list of available drivers. I just gave up and put the printer on eBay. I'll just stick with my inkjet for now. What a shame. I really liked the Dell printer.
     
  6. Giuly, Nov 6, 2013
    Last edited: Nov 23, 2014

    Giuly macrumors 68040

    Giuly

    #6
    Seriously though, the next time you run out of toner, take a look at a Brother HL-2270DW, HP or Xerox instead - because they actually work as intended.

    Anyways, I've spend five minutes and here's a fixed version of the driver installer: Download.

    Q: Does your installer actually work?
    A: Yes.

    Q: I'm not confident to install drivers that random people on the internets messed around with. Can I fix it myself?
    A: You surely can.
    1) Go to Dell.com and download the driver.
    2) Go into the MAC_Installer folder, right-click Installer OS X.mpkg and choose "Show Package Contents"
    3) Go to Contents/Plugins and open InstallerSections.plist with your favorite text editor.
    4) Remove "<string>WarningPlugin.bundle</string>"
    5) Repeat from step 2, but for MAC_Installer/MAC_Printer/Printer Driver Installer.pkg instead.

    It's so easy, even a software engineer at Samsung should be able to do it. And now he has instructions to copy the workflow, too.

    Q: What is the WarningPlugin that I'm removing?
    A: It's supposed to display a warning, but it just displays an empty window as in the OP instead.

    Q: What would that warning be?
    A:
     
  7. rav4x4 macrumors newbie

    Joined:
    Dec 24, 2013
    #7
    dell b1160w driver for mac10.9.1

    for anyone searching dell b1160w driver for mac 10.9.1. go to samsung site download driver for samsung ml-2165w. work like charm thru usb connected printer, still trying to figure out how to print wirelessly :):confused::apple:
     
  8. biacs macrumors newbie

    Joined:
    Jan 31, 2014
    #8
    Samsung drivers work with wifi on 10.9

    Download the Samsung drivers http://www.samsung.com/us/support/owners/product/ML-2525W/XAA#

    Install the driver, it's going to close all open apps so be sure you have documents saved, pages bookmarked, etc.

    Go to system preferences/printers & scanners/ add printer and select your wifi detected B1160W. Under the Use option click on Select Software and find the Samsung ML-2525W Series that will now appear in the list. Click Ok and that's it. I did not have to connect with USB first, mine was detected over my Wifi right away. If you are setting up the printer for the first time on your network you may have to use USB, my printer was previously joined to my SSID.
     
  9. Eriq macrumors newbie

    Joined:
    Feb 17, 2014
    #9
    Thanks a bunch for this! I just used your straightforward guide to get my Samsung printer rolling. It was - as stated - extremely easy to go around (obliterate) the warning thing. My thanks, again.
     
  10. redrich2000 macrumors newbie

    Joined:
    Feb 19, 2014
    #10
    This worked for me, thanks. I installed it with the USB plugged in, but chose the version of the printer than appeared in the drop-down when I clicked the + button to add a printer, rather than going to the add printer dialogue. Not sure if that was the USB or wifi detected version, but I unplugged the USB and it still works.
     

Share This Page