Printer drivers install location?

Discussion in 'Mac Basics and Help' started by eleven7, Apr 20, 2009.

  1. eleven7 macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #1
    Hi,

    I'm attempting to connect to a work place (windows based) network printer, so downloaded and installed my drivers. Installer says it all installed fine, but when I go to search for it when adding the printer, it's nowhere to be found in the list of installed drivers??

    I tried installing it again and rebooting but it still isn't in the list of printers. Can anyone think of why this might be, or just where it would most likely be installed to so I can manually choose the driver?

    The driver came as an mpkg file so I tried "Show package contents" but didn't see anything that resembled a driver file either.

    One other thing, I have a feeling the printer may be "Japan Only" but the installer contained both Japanese and English Instructions so I'm guessing that won't make any difference but thought I'd mention it just in case.

    Printer: Xerox Docuprint c830
    Driver: DPC830v10_3_3
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Open the .mpkg file with Pacifist, and it should show you where your drivers were installed. Macs come with about 3 GB of printer drivers preinstalled, though. Usually installing third-party drivers is unnecessary.
     
  3. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #3
    Another way

    Try this: Macs have the printer utility, CUPS (Common Unix Printing Service) installed and printers can be managed in this way. For access to this, paste the numbers 127.0.0.1:631 into your browser.
     
  4. eleven7 thread starter macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #4
    Thanks, managed to find the installed directory with Pacifist, however when I went to manually choose a driver file from the "Add Printer" utility it didn't do anything, what are the driver file extension for Mac anyway? I'm a new mac user so may have been looking for the wrong thing. I think the reason it isn't showing up in the installed driver list is that the installer installed it under the folder "FujiXerox", while all others pre-installed printer drivers are just in a "Xerox" folder.

    I will also give the CUPS utility a go next.

    The problem I'm having is that I managed to connect to one printer on the network but whenever I printed something out, it just printed a whole lot of PS code, so I'm guessing it doesn't support PS? I tried guten-print (the old gimp-print) but it didn't support either of the 2 printers on the network.

    Failing that, I'll give the other printer a go, just thought I would try and get the closest one to me connect first.
     

Share This Page