Printer "fails to connect to server" - AirPort Express

Discussion in 'Mac Accessories' started by moogwife, Aug 24, 2011.

  1. moogwife macrumors newbie

    Joined:
    Aug 24, 2011
    #1
    I have had my Brother HL2070N printer connected to the Airport Express to enable print share between our two computers (I have a Macbook Pro and my hubby's got a Macbook). This arrangement has been working fine for ages now.

    Just recently, and seemingly out of the blue, our printer has stopped connecting to the device.

    When I click on the Print Utility, everything is fine but it fails to make the connection. It's like this on both computers. I can connect using the USB cable directly to the printer and it prints fine. I tried the Network Diagnostics and everything is good, until the printer tries to connect to the server. I'm able to connect to the internet okay but not the "server."

    I tried deleting and re-adding the printers, but same problem pops up. I tried powering down the printer and turning it back on. Still the same.

    My husband recently connected speakers to the Airport. Could this be affecting the printer?? Actually, come to think of it, the speakers aren't working either.

    A good answer to this question will not include the words "ask your husband for help," as he is more clueless than I am when it comes to the computer! (but still he's a loveable luddite!)

    This is my first time posting to an online forum in a long, long, time. But I have often checked on the MacRumors forums for help in times of need and trust the community and its advice. Thanks in advance for any help!!
     
  2. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
  3. moogwife thread starter macrumors newbie

    Joined:
    Aug 24, 2011
    #3
    Do you mean have I unplugged the Express and re-plugged it? If so, yes. If there's another way, please let me know!
     
  4. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #4
    Yes, that would restart the Express. How are you connecting your printer to the Express? Have you tried unplugging the speakers and seeing if it works again?
     
  5. theVoiD macrumors newbie

    Joined:
    Feb 22, 2012
    #5
    restarting the express worked fine.
    While unplugging it didn't work, just updating did the trick.
     

Share This Page