Printer Hangs with "sending data"

Discussion in 'Mac Basics and Help' started by eklhad, Mar 25, 2007.

  1. eklhad macrumors newbie

    Mar 24, 2007
    I have an hp officejet k80xi printer, which is not supported by the Mac
    directly, but is supported by
    I installed ghostscript, and hpijs, but when I print, I get nothing,
    with the phrase "sending data".
    As a test, I moved the printer back to the Windows box, where it has lived
    for the past 3 years, and sent the print job across to windows via samba.
    That worked fine.
    So the hpijs driver works.
    Its fine if I send the job over the ethernet cable to another box running the same printer.
    But the page gets lost going across the usb cable and into the printer.
    When the printer is on windows, it also connects via usb,
    so printer on usb works.
    When the printer is attached to the mac, the Mac sees it,
    and identifies model and serial number.
    So Mac plus usb works.
    Still, the page doesn't make it over to the printer across usb.
    I could leave the windows box running as a print server,
    and will probably do so for a while, until I can buy a supported printer,
    but I can't figure out what is wrong with the direct usb connection.
    I went to /usr/libexec/cups/backend/usb and ran it
    directly, with -v and -V, but it wasn't kind enough to give me
    its version number, so I don't even know what version I have.
    It came with Tiger 10.4.8.
    Are there known bugs in backend/usb?
    Any reason it won't work with hp jet k80?
    I'd hate to buy another printer and have it not work over usb,
    if the problem lies in the backend usb program itself.
    I've worked on this one for a while, and don't have a clue.
    Many thanks.
  2. pithief314 macrumors newbie

    Mar 25, 2008
    Try going to and downloading the Mac driver for said printer.

    It would appear that the problem is between the Mac and the printer, namely the protocol that the Mac is using. If the two decide on not talking right, then at times it will just sit at "sending data" without ever doing anything. As you found out, the cable is good, the printer is good, and the driver is good, but that does not mean that the driver likes Macs.
  3. merl1n macrumors 65816


    Mar 30, 2008
    New Jersey, USA
    He already stated that it is not supported on OSX by HP. I verified this. The only drivers are for Windows.

    What you need to do is System Prefs -> Printing and fax.

    Add printer (usb) and select the "Officejet K80xi - Gutenprint (5.1.3)" driver.

    Here is the link to supported printers under Leopard:

Share This Page