Printer Help !

Discussion in 'Macintosh Computers' started by eyelight, Aug 20, 2004.

  1. eyelight macrumors member

    May 24, 2004
    Replaced the colour ink cartridge in my Epson 980 this morning. All was working fine, but about half an hour later in the middle of printing a Word document with a few colour photos, the print quality took a nose dive. Colour turned to brown, sepia like tones and then got worse when I tried to print another page. Did nozzle check and the colour pattern didn't even print at all. Tried a few more times, and once got the full pattern to print, but then I cleaned the nozzles and it was back to the same. Shows that the colour tank is full, (I know this is only a timer), but all files I try to print come out with only the black parts printed. Any ideas ? Only thing I can think of is that I saved the file I was printing in the middle of the printing. Can't think what this would do or why it would change anything, but who knows....
    Is this likely to be a problem with the printer or the computer ?
    When I did a search for anything that might have been modified when the printer started going screwy, all i came up with was this

    Could this be related ?

    Any advice appriciated.


    Larry - G4 Powerbook 15"
  2. blodwyn macrumors 65816

    Jul 28, 2004
    Portland, Oregon
    The most likely culprit is the ink cartridge, it's either faulty, has an airlock, has blocked nozzles, or not seated properly. I would remove it and then carefully re-install it and try again. If no luck then remove it again, wrap it loosely with kitchen roll, and with the nozzles downwards (over the sink or something you don't mind getting ink on) shake it up and down fairly energetically a few times - this will dislodge any air bubbles. If still no luck then try a new cartridge. Genuine Epson cartridges are usually more reliable than substitute ones, but Epson printers in general seem to clog up if they're not used much.
  3. AmigoMac macrumors 68020


    Aug 5, 2003
    is it possible...?

    I'm not 100% sure, but just after the 10.3.5 update, my printer started to work choppy, with new ink, had to install it again and gave 2 days about color problems... and still is not working well... maybe is just me but it was the hour after the update...
  4. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    I would use the Epson Printer Utility and do a nozzle check and clean, as necessary. Since the print head is not part of the ink cartridge, it tends to get clogged separately.

Share This Page