Printer Installation Help

Discussion in 'Mac Basics and Help' started by SupaPowa, Jun 11, 2008.

  1. SupaPowa macrumors newbie

    Joined:
    Jun 11, 2008
    #1
    Hi all, I'm new to the forums. I did a quick search and couldn't find out what's wrong with my Mac setup.

    My first problem is that I cannot seem to install programs on my Mac. I log in as Admin to my Mac Account and when I try to install software, it says that I need to login as Admin. It says that I do not have the correct privileges even though I'm pretty certain I'm Admin! I checked the User Accounts and did not see anymore logins. The software I'm trying to install is for an Oki C5200n and I've tried using the drivers from the web site and from the CD. The computer still won't let me install :(

    The reason I'm trying to reinstall my printer drivers is because I have a network of Mac's that print through one Mac (Mac OS X 10.4.11). That one Mac is directly connected to the printer. The Mac that is directly connected to the printer cannot print! Every computer in the network can print through the network except the one that is directly connected! I have tried different documents using different programs to no avail. (Which is then why I tried to reinstall drivers - see above problem)

    If anyone could help me or give me advice, it is much appreciated! :)
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Open Terminal.app, type in:

    id

    Hit Return. What did it display?

    Code:
    yellow$ id
    uid=501(yellow) gid=20(staff) groups=20(staff),98(_lpadmin),81(_appserveradm),79(_appserverusr),80(admin)
    
    If you're not in group 80, then you're not an admin.
     
  3. SupaPowa thread starter macrumors newbie

    Joined:
    Jun 11, 2008
    #3
    Ok I was able to uninstall the file (clear Printer preferences?), but it's not letting me print on that computer that is directly hooked up to the network drive now. Thanks yellow for the quick reply on how to find out if I was admin.

    I guess Mac's install files on more than one location and I can't reinstall it without deleting some of that first?
     
  4. SupaPowa thread starter macrumors newbie

    Joined:
    Jun 11, 2008
    #4
    Reinstalled the drivers on the Mac that's directly connected to the printer, then had all the network printers delete their 'shared printer' and readd it. Finally it worked!
     

Share This Page