printer not beeing seen by Mac anymore!

Discussion in 'Mac Basics and Help' started by new2macAllen, Apr 1, 2011.

  1. new2macAllen macrumors newbie

    Joined:
    Dec 8, 2009
    #1
    My mac has suddenly stopped "seeing" my hp2025 printer.

    I was trying to use the printer through Windows via VMWare, and that wasn't working, so I tried reinstalling the printer in windows. That still didn't work, so I gave up and closed VMWare, deciding just to print through Mac instead.

    However, with VMWare closed and back in the Mac environment, the printer still wasn't working (all was working fine before all of this)

    So, I tried "Reset Print System", and carefully read the warning prompt which said all print queues and waiting jobs would be deleted. It DID NOT mention that all my printers would be removed from my system.

    Again, wouldn't be a major deal, just a nuisance to re-install printer. BUT NOW, the mac is not seeing the HP CP2025 laser jet at all. I have tried all kinds of things.. deleted pref files, reset permissions, downloaded new drivers from apple link (a 600MB file installed!?). I've removed all cables, shut off printer and removed power, rebooted, everything I could think of or have seen suggested... but the Mac is still not "seeing" printer when I go to Add Printer. All I see there is my Adobe PDF driver.

    So, I'm very frustrated to say the least. Can someone PLEASE help me out, thanks so much!
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Download the shareware program Print Therapy (it has a 7 day trial) and see if it can fix the printer drivers.

    Plus you mention that Windows couldn't find the printer. This tells me that something in the printer itself might be going on. Have you restarted the printer and checked it's toner cartridges and or paper?
     
  3. new2macAllen thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #3
    Well, Windows (run through VMWare on my Mac) saw the printer, but nothing would happen when I print to it. Before opening Windows, the printer was working just fine, I use it daily.

    So, when it wouldn't print properly in Windows, I thought maybe I had to re-install the printer in Windows. I wasn't sure if I had used it with Windows yet. This printer is about 2 weeks old, and has been working fine in OS.x.. So, I installed the printer from CD in Windows, however, when I got to the part that said "Connect USB and click Next" I couldn't get past there, since the printer was already connected (as I had been using it with the Mac for 2 weeks). I tied unplugging and re-plugging the USB, but to no avail.

    So basically, I probably caused this somehow, but i still dont see why the Mac cant see the printer anymore after I clicked "Reset Printer System" - after many failed attempts to make everything work correctly again.

    Figures all this would happen after using Windows (XP) which is why I switched to Mac in the first place. The only reason I use VMWare for Windows is to use MS Access for one element of my work. Otherwise, I'd never touch Windows again.
     
  4. new2macAllen thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #4
    Oh yeah, thanks for the tip on Print Drivers, I'll check that out as soon as I can!
     
  5. new2macAllen thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #5
    solved!

    User error, as usual :)

    Feel pretty dumb to admit it, but once I disconnected everything, I apparently was not reconnecting correctly. Rather than move the heavy printer, I was "feeling" around the back where the USB cable plugs in. Apparently, the ethernet plug is directly above the USB cord receptacle (and slightly bigger) - so, it appears that I was plugging the squarish end of the USB into the ethernet port rather than the proper location.

    haha, oh well. I had a feeling I was ding something drastically wrong, nothing was making sense....

    I'm just posting my solution in case someone else makes the same mistake...
     
  6. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.

Share This Page