Printer not working in Airport/Time Capsule?

Discussion in 'Mac Accessories' started by tempurature, Oct 18, 2012.

  1. tempurature macrumors newbie

    Sep 20, 2012
    My Canon MX340 is currently connected via USB to my AirPort Time Capsule. It was not working at first, but I reinstalled the drivers on each computer (There are five total, 4 of them Macs, 1 of them a PC) and it seemed to work, even on the PC. It was working for a couple days and now it is back to not working.

    When I try to connect on one of the Macs via AirPort, the printer does not show up at all (yes, it is plugged into the AirPort device). I read that you have to manually connect the printer to the computer via USB, but that is not an option as I cannot drag the printer to five different computer stations.

    I reset the printer options in preferences (Mac) and when I go to add the printer again, it still does not show up. I tried turning the printer on and off, unplugging it, etc.

    Someone PLEASE tell me how to wirelessly connect all computers (including the PC) to the printer, via AirPort/Bonjour, and have it STAY connected.
  2. Brian33 macrumors 6502a

    Apr 30, 2008
    USA (Virginia)
    What you're trying to do should work, but I don't know why it's not.

    I have a (1st-gen) Time Capsule and it shares the Canon iP4900 printer to two Macs and a PC. When I go into Airport (I assume that's what you meant) my printer shows up there under "Printers". If your doesn't show up, that certainly seems to indicate a problem. To me, that makes the problem seem more between the printer and the TC, and not about the client computers, but that's just a guess.

    You've probably already tried powering on the TC and printer in different orders. I suspect power on the printer first, and then the TC, will give you the best chance of a good result, if you haven't tried that yet.


    If I'm wrong about it being a problem between the printer and the Time Capsule, and you think it might be a problem from the Mac, you could look in the printer log files for clues. I don't know really how to read them but you might see something...

    Open, make sure the log list is showing in the left pane (View-->Show Log List).

    Open /private/var/log
    Open cups
    click on access_log or error_log or page_log.

    You might need to do this from an Administrator user.

Share This Page