Printer on Network Problem

Discussion in 'Mac Accessories' started by Ironduke, Jun 19, 2009.

  1. Ironduke Suspended

    Ironduke

    Joined:
    Nov 12, 2006
    Location:
    England
    #1
    I recently purchased an Epson PX700WF printer. I have 2 Routers in my network, A 2008 Time Capsule & a DLink Dir-635.

    The reason I have two routers is the Time Capsule operates in N mode and the Dir-635 operates in G mode so all my devices can connect to the network.

    The Time Capsule is the main Router which connects to the Cable Modem, The Time Capsule is also connected to the Dir-635 via Ethernet Cable.

    here is a pdf showing my network.

    The problem I have is my macbook or any machine connected to the Time Capsule, can see the printer (which is on the Dir-635) but cant use it.

    If I change my macbook to use the dir-635 it works fine.

    I think it's obvious while I have set my network up to work for internet access that the dlink is acting as a seperate network within the Time Capsules Network & not an extesion of it.

    Any Ideas, if I cant get this working by sunday evening I think I might just buy a dual band airport.
     
  2. gsahli macrumors 6502a

    gsahli

    Joined:
    Jun 1, 2007
    Location:
    Chicago
    #2
    Good illustration. You are correct, it is two separate subnets.
    You need the second router to be in bridge mode. This means turning off DHCP server, so everything on "G" will get their IP addresses from the first router. Router manufacturers often have instructions on their website. Typically, besides turning off DHCP, you have to plug the "input" ethernet into a LAN port on some models, yet other models require it to still go to the internet/WAN port. Try both if you don't find instructions.
     
  3. skorpien macrumors 68020

    Joined:
    Jan 14, 2008
    #3
    Go into your D-Link's settings and navigate to this page:
    http://support.dlink.com/Emulators/dir635/Basic_Network.html
    Then uncheck "Enable DHCP Server" under the "DHCP SERVER SETTINGS" subsection. Then do as gsahli suggested by plugging the incoming ethernet cable into one of the router's LAN ports rather than the WAN port. And if that doesn't work, plug it back into the WAN port.
     

Share This Page