Printer problem need help asap!!

Discussion in 'Mac Accessories' started by eyebeaz, Apr 23, 2007.

  1. eyebeaz macrumors 6502

    Joined:
    Oct 22, 2006
    #1
    I have an HP PSC 1350 All-In-One printer which has not failed me at all. Today I plug it in and try printing something only to realize that the printer no longer showing up on the print menu, and when I attempt to add the printer, it says "server-error-service-unavailable". I opened up the HP software, and even printed a test page so clearly the printer is communicating with the computer.. any ideas?
     
  2. flyfish29 macrumors 68020

    flyfish29

    Joined:
    Feb 4, 2003
    Location:
    New HAMpshire
    #2
    How are you connecting to the printer...directly through usb, through network, how?

    I have not had great luck with my all in one HP at my school...isn't there an HP utility for the printer? Have you tried using the printer utility in your applications...utilities folder? Just a few ideas.
     
  3. eyebeaz thread starter macrumors 6502

    Joined:
    Oct 22, 2006
    #3
    Yea I have tried most everything. I am using a USB cable. I find it so strange that all the HP software/drivers are still installed, and I can even request a test page to print from the computer, but it won't load up as a printer in the printer utility.

    Oh yea and.. apparently HP does not have the drivers for this printer online.. great.
     
  4. flyfish29 macrumors 68020

    flyfish29

    Joined:
    Feb 4, 2003
    Location:
    New HAMpshire
    #4
    Have you tried printing from another application? Word, Safari, Text edit, etc? It may be something with the app you are trying to print from?

    Also, have you tried printing a test page directly from the all in one to make sure it is working ok?

    Also, restart the application you are trying to print from...and restart the whole computer in fa ct...
     
  5. QuantumLo0p macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #5
    After checking to print from other apps, you may want to try to delete the printer configuration and reinstall it. If you have the original install disk you may want to try it or try reinstalling it without the disk and see what OS-X comes up with when/if it detects it. You would still need to find a Twain driver.

    For my laser Brother MFC I used the driver that my PowerMac came up with, albeit with a switch I added to rectify print jobs printing in reverse order. As for scanning I used a Brother Twain driver. Thankfully everything works.
     
  6. orangemacapple macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Raleigh
    #6
    i had a similar problem with an epson printer last winter.

    emailed epson what to do. said i had a corrupted file somewhere. they told me to delete the printer from printers list and i used spotlight and deleted ANYTHING ANYWHERE that said epson on the entire hdd. i wouldn't need the other epson drivers and such that came with the os. then do an install from the epson install disk.


    it worked
     
  7. eyebeaz thread starter macrumors 6502

    Joined:
    Oct 22, 2006
    #7
    I was able to find the printers drivers on the HP website, and after unistalling all the HP software, I re-installed it. The final step was adding the printer to the printer list in the Printer Setup Utility. This is where the drivers are not detected, and it will not let me add the printer. I am starting to think it is a problem of some sort with the computer itself. Anyone?
     
  8. flyfish29 macrumors 68020

    flyfish29

    Joined:
    Feb 4, 2003
    Location:
    New HAMpshire
    #8
    Have you tried a different usb port as well as a diff. cable? maybe a bad port, cord or something...just want to rule out everything.

    Also, I assume you have printed from other applications. How about printing from another user name...do you have another user name set up on your computer? Might try that- or set up a dummy account and then try to print.
     

Share This Page