Printer problems

Discussion in 'Mac Basics and Help' started by DylanWalker, Jan 1, 2009.

  1. DylanWalker macrumors newbie

    Joined:
    Jan 1, 2009
    #1
    Hey guys,

    I've browsed the site for awhile now, but this is the first time I've had to post.

    I recently tossed my old printer due to the scanner going bad, and picked up a new one. It's an Epson NX400. I've gone through the install disk, done what needs to be done, but I've got a problem.

    Whenever I go to add it in the printer utility window, all I can do is highlight it. To clarify, it's showing up just fine under the 'Printer Name' section, and the 'Name' and 'Location' both fill in with the appropriate information when highlighted, but the 'Add' button doesn't become selectable.

    It forces me to look through the 'Print Using' window, where the desired printer is nowhere to be found. This also happened when I tried hooking up an HP printer.

    I've been scratching my head going through every support site I could find, but I'm giving up. Anyone familiar with a fix? :confused:

    -Dylan
     
  2. Solemony macrumors 6502

    Solemony

    Joined:
    Nov 26, 2008
    Location:
    Wonderland
    #2
    I just recently set up my HP printer to my iMac G5 not too long ago. I didn't have any trouble. Did you thoroughly read through the steps provided by the manual book? If you did you shouldn't have any problem setting up the HP printer. For the HP printer I believe you have to configure the printer first like turn the power button on then you'll have to select print, then, scan, copy but not sure which order comes first but it should say on the book. Then you'll have to install the disk that come with it. Maybe try restarting your computer see what happens?
     
  3. DylanWalker thread starter macrumors newbie

    Joined:
    Jan 1, 2009
    #3
    Solemony,

    I appreciate the response!

    Unforunately, I've been following the instructions to the last detail. It doesn't suggest restarting the computer, but I'm going to give it a try as soon as I'm done typing this. If it fixes the problem, I'll post a reply here. Otherwise, you guys will know it didn't work.

    Again, if anyone can share their knowledge, I'd appreciate it.
     
  4. Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #4
    I had a somewhat similar problem last year; I switched to a MBP (from a Toshiba) last April, and I wished to link it up with a small laser Dell printer which I was perfectly happy with and did not wish to have to change.

    The Dell did not feature on the MBP's identity list, of appropriate or compatible printers, and so they did not recognise one another. The solution was a bit complicated, and basically involved fooling the computer by downloading a driver so that my MBP could be persuaded that it was shaking hands with a printer that it thought it was compatible with. This means, now, that in the printer window a totally different icon appears (a Sigma, one of the closest "foot-prints/finger-prints" to the Dell in question) to the printer that the MBP is actually hooked up to, namely the trusty Dell. Bizarre though it sounds, it actually works. Hope this helps.

    Cheers and good luck
     
  5. gumshoestu macrumors newbie

    Joined:
    Feb 28, 2009
    #5
    NX200 has the same issue ...

    Folks,
    I just received a replacement Epson NX200 -- my CX7400 shot craps recently -- and I can't add the NX200 to my printer list because it isn't listed on the software. Anyone have any ideas?:confused:
     
  6. sasin9 macrumors newbie

    Joined:
    Mar 22, 2009
    #6
    Nx200

    There is absolutely no fix for the NX200 that I can find on the internet, and not even a single mention except for the two posts on this site. I installed the software on the CD and it still wont add the printer to the list. I downloaded the driver and still nothing happens.
     

Share This Page