Printer probs HP 7350

divein195hi11ar

macrumors newbie
Original poster
Aug 9, 2006
26
0
Having a bit of a problem with the HP photosmart 7350 printer. I downloaded the software driver and installed it but i try to send someting to the printer and it will not print. When i go in to the printer setup i see the printer there but i select the printer in the dropdown box to select the printer and the printer driver is not listed. But it recognizes the printer. but not able to print
 

michael7136

macrumors newbie
Sep 18, 2007
1
0
HP 7350 Problems

I also have a friend with the same problem trying to print from OS X 10.4.x to an HP Photosmart 7350. We also tried the HPIJS printer drivers from sourceforge.net and got the same "waiting for printer" issue. At this point, I've put in an hour to troubleshooting the problem and it's just less of a headache to buy a new printer since I don't know if it will take an hour or 10 hours to fix the problem.
 

AndyW

macrumors newbie
Nov 22, 2007
1
0
HP 7350 work-around

After upgrading to Leopard on a PowerPC-based iMac, I too could not print with my Photosmart 7350. I got the "GenericClass: waiting for device..." error. I've read that the Photosmart 7350 is not supported anymore for Intel-based Macs, but I haven't been able to find any info as to whether PowerPC-based Macs suffer from the same problem.

Therefore, in this information vacuum, I decided to press on, and I've found a crude work-around that works for me. Maybe someone can use this info to figure out how to fix this problem. Anyway, this is how I get the printer to print. I put the computer to sleep. Just as the screen goes dark, I immediately hit the space bar, waking the computer up again. This somehow reestablishes a connection between the computer and the printer, allowing me to print. It will remain "fixed" until the computer sleeps again.

I don't know if this will work for anyone else, but i can say that using this method, I can print to a 7350 while running Leopard.
 

mvian

macrumors newbie
Feb 22, 2008
1
0
Can't print to photosmart 7350 with Leopard

...but I haven't been able to find any info as to whether PowerPC-based Macs suffer from the same problem.

I put the computer to sleep. Just as the screen goes dark, I immediately hit the space bar, waking the computer up again...
PowerPC Mini - same problem
Absolutely staggering, but this fix (workaround) worked for me too.

-- except I had to lift my left foot off the ground too...
 

vdutell

macrumors newbie
Jul 20, 2008
1
0
jaw on floor..

i created an account here just to write this...

i'm on an intel macbook recently upgraded to leopard...i finally tried the sleep & spacebar thing after running out of hope having tried everything else and i can't believe it worked! i'm stunned.
thank you for the discovery :)
 

love4latrice

macrumors newbie
Aug 18, 2008
2
0
Thank you

I've been puzzled over an hour now:mad:- I should have just came here 1st:D

I put my computer to sleep, hit the space bar and surprise the picture printed. WOW

Thanks for the advise
LIJ:apple: