Printer repairing permissions - now I have a trojan!?

Discussion in 'Mac Basics and Help' started by Yavmagru, Nov 21, 2016.

  1. Yavmagru, Nov 21, 2016
    Last edited: Nov 21, 2016

    Yavmagru macrumors newbie

    Joined:
    Nov 21, 2016
    #1
    Installed gutenprint drivers, printer said something about problem during installation (or maybe it was software for the printer installed incorrectly), wanted to make changes and repairing permissions.

    [​IMG]

    Did it, nothing else happened. Printed one page, but printer refused to work, couldn't even shut down (button just burns green). Had to remove cable to force shut down. Works completely normal with Windows.

    Removed drivers, installed again, this time no asks about repairing permissions, but same thing. Kicked gutenprint out.

    Printer asking about repairing permissions means there was some error, but nothing serious or suspicious?
     
  2. Robert_James_the_Third macrumors newbie

    Joined:
    Nov 22, 2016
    #2


    Okay, you are in very big trouble now!

    http://www.macworld.com/article/1052220/software-utilities/repairpermissions.html


    Every file and folder on a Mac OS X hard drive has a set of permissions —settings that determine which user(s) have access to each item, and exactly what that access is. For example, permissions dictate whether or not a particular user can open and edit a particular file. But permissions also determine which items the operating system—or specific parts of it—can access and modify, and which files are accessible by applications.

    If permissions on particular files are “incorrect”—i.e., not what Mac OS X expects them to be or not what they need to be for your Mac’s normal operation—you can experience problems when the operating system tries to access or modify those files.


    The Repair Disk Permissions function—the process that actually performs the task of repairing permissions—examines certain files and folders on your Mac’s hard drive to see if their current permissions settings are what Mac OS X expects them to be; if discrepancies are found, the offending permissions are changed to match the expected settings.


    It talks about disk permissions function. Not any other app using repair permissions. You say printer did this. Permissions are permissions. Meaning printer or gutenprint drivers did something, hacked in and now you need to do clean install because your mac is hijacked by trojans.
     
  3. Yavmagru thread starter macrumors newbie

    Joined:
    Nov 21, 2016
    #3

    Wait, WHAT?!
    So, if any program besides Disk Utility talks about repairing permissions, it means I have a trojan? What do I have to do now then!? O_O
    I just thought there was at most some system instability...
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    Robert_James_the_Third is talking nonsense. It is very well possible that an application checks and changes permissions, such as its own permissions and of directories that it relies on. Every installer sets its own permissions as well, that’s part of the procedure.

    Can you give a bit more information about your system?
     
  5. mkelly macrumors regular

    Joined:
    Nov 29, 2007
    #5
    Likely nothing serious. If you don't mind, I'm going to go on a bit of rant here about repair permissions (mostly in response to the rather alarmist post by Robert_James_The_Third). If you don't want to read all of this, just jump down to the last paragraph or two at the bottom of this post.

    First, a quick aside: as a unix sysadmin with nearly 30 years of experience under my belt, it's *extremely* painful to read posts in Mac support forums about "repairing permissions". It's often treated as some sort of magical voodoo cure-all, or curse, depending on who is posting. File system permissions are nothing magical and it can be (and is) entirely normal for the permissions of a file to change over its lifetime.

    Permissions being which user/group owns a file, and whether it's readable/writable/executable by the owner, group and every other account on the system.

    A little history: Repair permissions was originally introduced in OS X back when OS X was in beta and most Mac users ran the *old* non-Unix MacOS operating system. If you had both OS X and Mac OS 9 installed (for dual-booting), it was possible that OS 9 (which did not have a concept of Unix-style file permissions) could inadvertently alter the permissions on some of the OS X files. So Apple built a repair permissions feature into Disk Utility and it has been there ever since.

    The Repair Permissions feature in Disk Utility goes through the system files as well as any apps you may have installed one-by-one, and compares their current permissions with a record of the permissions set when the app was originally installed. If there's a difference, Disk Utility changes the permissions back to the original setting.

    The trick is though, that there may be good reasons for permissions to change - e.g.: when you first install an app it may have one set of permissions (owner: you, group: staff, readable, writeable, executable). But after you run the app for the first time it may need to elevate its permissions. Or an update might come along and the new version of the app installs with slightly different permissions.

    Now in the case of your printer driver, it looks to me like the developers used the phrase "repairing permissions" for a stage of the install which likely changes the driver file owner so that it's owned by the print server application on your Mac. Why it doesn't print properly is another question (some of the Gutenprint drivers are flaky - such is the life of open source print drivers). And when you reinstalled it, the installer was likely smart enough to notice that the drivers you installed previously already had the correct permissions set, so it didn't need to "repair" them again.

    So in closing: You almost certainly don't have a trojan. You likely have a poorly-written open-source printer driver problem. And when it comes to repairing permissions, remember: unless you're dual-booting OS X and OS 9 (on a PowerPC Mac!), 99.9% of the time it's voodoo.

    Now: Which printer and version of OS X are you trying to get to work together? Maybe we can help.
     
  6. Yavmagru thread starter macrumors newbie

    Joined:
    Nov 21, 2016
    #6
    Oh, thank you so much! I had a panic attack here...
    What is required? Mac mini (Late 2014), OS X El Capitan 10.11.6
    --- Post Merged, Nov 22, 2016 ---

    Thank you so much! I was getting scared here with no info and then... that info.

    I read it all, thank you for summing it up so well.

    So grateful for you for wording this out. I couldn't find any explanation for this particular situation before.



    My system OS X El Capitan 10.11.6 and my printer is very old ink colour Canon MP 160. It has been with me for many years, so perhaps it is just too old. I used CD to install the scanner function into Mac, but despite it CD saying that there were drivers there, installing them didn't really give me anything. When I tried to add printer ,there simply was nothing in the menu.

    So I tried 2 times with gutenprint and now it let me add, but after printing out one page, it refused to do anything. I just got too tired trying again after every time I put printer on, it refused to do anything and even pushing the ON/OFF button, didn't help me. It just keeps burning green. I had to pull the power cable off from printer, then put it back. Then it was back to fine. Until I tried to print.
    I heard something similar happening to when trying to put old printers together with Mac.

    I have one new, black and white HP laser printer that luckily works. If I can't get Canon work, it's fine too. Scanner at least works. If it was just software not working well together, then I'll take a deep breath and not worry about things I can't change.
     
  7. wordsworth, Nov 23, 2016
    Last edited: Nov 23, 2016

    wordsworth macrumors regular

    Joined:
    Apr 7, 2011
    Location:
    UK
    #7
    Excellent post from mkelly. This is the sort of thing that helps make the Mac Rumors forum such a great resource.


    To the OP, just out of interest, were you using the printer on a different, older Mac and then upgraded your computer with a view to continuing to use the old printer? Or did you upgrade your Operating System on the same machine that the printer was working with? If the former, then try copying the driver for your Canon printer from your older machine and installing it on your new machine.

    Apologies if I'm stating the obvious.

    Just to add a bit more information, as background to my above suggestion, I recently got an old Canon iP4300 inkjet printer working on a much newer Mac by using the old driver for it, which I lifted from my 2009 MacBook (that I still use as a desktop machine). This Canon inkjet was, I believe, manufactured the year after your own Canon printer. I'd actually given the iP4300 to a family member two or three years back and it worked fine on their Mountain Lion iMac system but when they later upgraded their iMac Operating System, the printer would no longer work. They gave it me back and it worked fine on my MacBook with Snow Leopard, as it had always done.

    I then offered the same printer again to the same family member just last week for possible use with their 2015 MacBook, when they were in need of a printer. However, it wouldn't work until I provided a copy of the driver from my old MacBook, which they duly installed. The printer is now fully functional. (I'm not sure whether they are using El Capitan or Yosemite.)
     
  8. Yavmagru thread starter macrumors newbie

    Joined:
    Nov 21, 2016
    #8
    Indeed, mkelly pretty much addressed all of my issues and gave very thorough explanations.

    None of that. I was using this printer on Windows and when getting new Mac Mini after my trustworthy Windows started showing signs of dying (and I simply refuse to touch those new Windows models), decided to move completely to Mac (therefore not having old Windows to rely on when it comes to old Canon printer).

    I think I bought it about 13 years ago and got two CDs. One was Canon Pixma MP160 for Windows and other for Macintosh. Windows one I have used several times for at least 2 or 3 Windows computers.
    Macintosh I took out only now.
    Windows one (and I think Mac one too, but I lack access to my Mac at the moment so I can't check) contains MP Drivers, On Screen Manual, MP Navigator, Easy-Photo Print, ScanSoft OniPage SE, Easy-Web Print and Arcsoft PhotoStudio

    In mac I remember I only installed the drivers (that didn't work at all) and the parts for make scanner work.

    Funny thing, years ago my anti virus found trojan in Arcsoft PhotoStudio after having it in my computer for some time. Don't know if it was false alert or something sneaked in while surfing and it had security hole or something.
    I mean, when buying printer-scanner and getting official CDs, the likleyhood those being infected and that kicking out only some time later is kind of impossible, right? And as they are so old, if those were infected, current anti-malware programs should find issues right away? Both in Windows and Mac?

    Thank you, wordsworth! Seems like time really is cruel mistress and old models don't work well with new ones. Out of curiosity, I stuffed the installation CD into Windows 7 and it kept warning me that it has known compatibility issue.
    Well, if old Windows is too new for this...
     
  9. wordsworth macrumors regular

    Joined:
    Apr 7, 2011
    Location:
    UK
    #9
    It seems, from an old review on the web, that the Canon Pixma MP160 was launched in 2006, the year before my own Canon iP4300. If that's the case, I'd persevere. As I said in my previous post, I was successful in reviving the printer for use on a more up to date Mac.

    Try this: go to this Canon site

    https://www.usa.canon.com/internet/.../support-inkjet-printer/mp-series/pixma-mp160

    (copy and paste this address into your browser if it's not actually an active link)

    and then look for the option to download the drivers for your machine. According to the web page, the scanner driver was last updated by Canon in 2011. The printer driver was last updated by Canon in 2014. (You say the scanner works anyway, but I'd still download the scanner driver and keep it as a back up for some future possible scenario.) Of course, it's the printer you are focused on, and so it's good that the driver was updated as 'recently' as 2014

    Install the 2014-updated printer driver on your current Mac machine. (This driver will be more up to date than the driver you used from the Installation Disc, which came with your original printer purchase.)

    You may well find that while the most recently-updated printer driver is admittedly long in the tooth, it will still be recognised and will work with your current Mac system. Give it a go at any rate.
     
  10. Yavmagru thread starter macrumors newbie

    Joined:
    Nov 21, 2016
    #10
    So this is official safe site - I admit, it's a bit strange that drivers are right there in net, when I'm still used to relying on CDs. :)
    Thank you for your help! I'll try to see if I can get this to work.
     
  11. Egradomulous, Dec 20, 2016
    Last edited: Dec 20, 2016

    Egradomulous macrumors newbie

    Joined:
    Dec 20, 2016
    #11


    Hello, Macrumors people!

    When I was trying to install Gutenprint I got this window about repairing permissions. For me, I got scared that something got broken from installing those drivers (repair!). Now seeing this thread I am even more confused about trojan fears...

    Is general consensus that when during installation (in this case Gutenprint drivers like OP) comes up window like that about repairing permissions, it is completely normal and not sign of damage/malicious software?

    For me, I also removed Gutenprint. Guess tech moves too fast for old printers and new Macs to work together. :(

    EDIT:

    The bold part - do I understand correctly this is when Mac makes the outside coming (downloaded, then installed) driver its own = before Gutenprint owned this driver, now the Mac, where it is installed into, owns this driver?
     
  12. hobowankenobi macrumors 6502

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #12
    1. Yes, installers can do whatever the builder wants them too.....including changing (repairing) permissions. Normal.

    2. Yes, when new OSes on new(er) Macs roll out, often Apple changes the printing system, which may mean that drivers need updates to work with the new changes. If the printer manufacturers chooses not to update their drivers to work with the newer OS for older printers....we are stuck with a printer that won't work. Keep in mind printer companies make no money writing new drivers for old printers; they do however make money selling you a new printer.

    3. Not really. There is no ownership. Either the driver is installed, and part of your OS, or it is not. The installer can be thought of as a script that is played to put things where they need to go. You could put the pieces there manually, but it could be tedious, cryptic, and....you might have to manually change some permissions. The installer automates all this.
     
  13. Egradomulous macrumors newbie

    Joined:
    Dec 20, 2016
    #13
    So nothing to worry about. :)


    So installer in this case made Gutenprint driver one with my Mac?
     
  14. hobowankenobi macrumors 6502

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #14
    Yes. The components were installed (moved into the correct locations) within the OS on your Mac.
     

Share This Page